macOS 10.13 Deployment Target: AU build fails


#1

When updating the OSX Deployment Target of my Plugin from 10.11 to 10.13, I can’t build an AU anymore:

/Users/work/Documents/JUCE/modules/juce_audio_plugin_client/AU/juce_AU_Wrapper.mm:456:22: Use of undeclared identifier 'kAudioUnitProperty_SupportsMPE'

I’m on the latest version of the develop branch.


XCode 10: -Wauto-var-id raises several warnings
#2

I’m not sure what’s going on there. I did the following:

  • Created a new plug-in project from the Projucer
  • Set OSX Deployment Target to 10.13 in the Debug config of the Xcode (MacOSX) exporter
  • Saved and opened in Xcode
  • Successfully built a debug AU plug-in