Midi Effect Plugin Jucer option having no effect?


#1

Hi, even if I check the option in Jucer I get an assertion when trying to load the VST:

Cheers


#2

Did you also override the isMidiEffect callback in your AudioProcessor?


#3

Hi - ah, no.

I’ll give that a go - is there any reason that Jucer doesn’t do that if the option is selected? I’m assuming I return true from that, so is there a circumstance where I’d return false?


#4

What file is that assertion in?

I’ve searched extensively through the develop branch as it stands and failed to find any instance of the string “You must at least have some channels”.