Missing wininet.h with JUCE 5.2 and Windows 10 SDK 10.016299.0

projucer
windows

#1

Getting compile errors using VisualStudio 2017 with JUCE version 5.2. I tried all the remedies here:


but none worked. I do have Windows 10 SDK 10.0.16299.0 installed and set Windows Target Platform to that value. This is my first attempt to use JUCE, and I’m not getting anywhere. Any help appreciated.


#2

Perhaps your SDK installation is incomplete. is WinInet.h located in C:\Program Files (x86)\Windows Kits\10\Include\10.0.16299.0\um?

Try re-downloading it from here.


#3

Also, if you open juce_BasicNativeHeaders.h, right click in #include <wininet.h> (line #135) and choose Open Document (ctrl + shift + G), you should get an error dialog, showing you where VS2017 is looking for that header. For 10.0.15063.0 SDK for instance you will get an error dialog with following search paths

So is VS2017 definitely looking for include files in the correct place?


#4

I had build error after updating to JUCE v5.2.
So I installed latest SDK of Win10.
And it’s all fine now.


#5

I did look in C:\Program Files (x86)\Windows Kits\10\Include\10.0.16299.0\um
and wininet.h wasn’t there. From the install log I saw that when installing the Windows 10 SDK that there was an error. Checked the corresponding Microsoft web page for the corresponding error, but that was no help. I tried reinstalling Windows SDK 10 and VisualStudio 2017 a couple of times as Administrator, but still got the same result (no wininet). And I did use that link provided by ed95, so it’s not a matter of trying to install the right version.

Then I thought maybe there was a compatibility issue between the Windows 8.1 OS, which I’m running and the VS2017 and SDK 10 (although it doesn’t appear that there should be per the Microsoft documentation), so I tried to install VisualStudio 2015. It told me that it installed but there were some problems. But the log link didn’t work so I couldn’t see any detail. I tried using it on a JUCE example anyway, and got a wininet.h error.

So at this point, it looks like some sort of pure Microsoft issue and not a JUCE one.

I’m a professional developer on Linux platform, and use cygwin as a hobbyist at home on my Windows PC, so I’ve never used VisualStudio and Microsoft’s development environment before. I would have thought that since they control their own ecosystem, I’d never run into problems like this. Yikes!

I know this is out of the JUCE domain now. But if anyone has suggestions though, I’m still willing to follow up on them.

Thanks again for the suggestions.


#6

Is it possible for you to try older versions of the Windows 10 SDK, or even the Windows 8.1 SDK? You can download them from Microsoft’s archive here.

You’ll need to set the corresponding SDK version in the “Windows Target Platform” field of the VS exporter too:


#7

Is anyone aware of the best SDK to be using to fix this issue? I ran into this problem after going to 5.2 (although admittedly I haven’t used windows in a while). I did a complete reinstall of Visual Studio as I thought that might be the issue. That didn’t solve the problem. I have now tried the latest SDK download (10.0.16299.15) just in case it was a .0 issue but again had no luck. Its also showing that gl/GL.h is missing too.

EDIT: I have tried a variety of SDK’s and I still am searching for a solution.


#8

I found this topic about gl/Gl.h stuff.


It might help your issue.


#9

Thanks for the suggestion, sadly it hasn’t helped though.


#10

Have you checked this?


#11

Winlnet.h is located there. Is it supposed to be wininet or winlnet?


#12

It don’t think it matters. Windows won’t care about capitalisation.


#13

If you’re using the live-build engine you also need to set the target platform version in the live-build settings here:

Currently this only supports SDK versions up to 10.0.16299.0 but I will replace it with a text field like in the VS exporters so any SDK version can be entered.