"Open in Visual Studio..." button is greyed out


#1

Hello!

I have installed a local git repository on a local computer from which I push and pull to and from several developer platforms running different OS, i.e. OS X, windows 7 and Linux.

I just started a new audio plug in project with the Introjucer from my OS X platform, which generated a .jucer configuration file and files for the XCode target. I pushed that file along with the whole repository to my windows 7 platform. There I loaded the .jucer file in the local Introjucer I have on that platform in order to generate files for the Visual C++ Express target.

But the “Open in Visual Studio…” and “Save Project and Open in Visual Studio…” buttons are greyed out. There seems to be no way around that. The only export target in the left panel is the “XCode (MacOSX)” which I already generated.

I would like to use the same configuration (saved in a single .jucer file) for all my targets/OS. Is that possible? Am I missing something?

Note that :

  • the Introjucer is of the same version on all platforms : commit 4a4b47979 pulled from git repo on sourceforge (February 3 2013)
  • said buttons aren’t greyed out if I create a new project on my windows 7 platform : everything works fine in that case

Thanks for reading this


#2

You’ll need to create an export target for Visual Studio before the button is enabled. Click on Config, then right click the project (at the top of the treeview) and create a VS target…


#3

Oh yeah, I missed that menu… Thanks!