Pendantic notification


#1

Mixing tabs and spaces: https://github.com/julianstorer/JUCE/commit/48ea4da185b5058f4c077a6b681f66d22ab50bcb


#2

Ahhh the joy of using Visual Studio....

Fixed on latest tip. Thanks for the pedantisism (<- is that a word?)

 


#3

Your statement's one sided as Xcode also uses tabs by default, on first installation.

Even so, it's easy enough to change that setting in Visual Studio, and Xcode for that matter.

In VS, navigate to:

  • Tools
  • Options
  • Text Editor
  • C/C++
  • Tabs
  • Check "Insert Spaces" and set the "Tab size" and "Indent size" to 4.

#4

Hmm I have that checked. Not sure how the tabs got in there then


#5

https://i.imgur.com/YsbKHg1.gif?noredirect ?