Plugin doesn't load in FL20

i have sent my new vst3 plugin to a friend with FL20, but he couldn’t start it. he gets the error message:

“something went wrong loading the vst3 fx plugin hdl audio slew tape. please make sure it’s installed and registered properly”

also an error saying that WCRUNTIME140_1.dll is missing on the computer. other people who have tried the plugin already confirmed that it worked in their daws, but i think none of them used fl, so that could be part of the problem. does anyone of you have any ideas?

edit: he downloaded the file, put it into system32 and then my plugin worked for him, but i still think this is worth a discussion because the normal vst consumer might not dare to add some fancy system stuff in order to run a plugin. how can i keep such stuff from happening?

This is the runtime, that is expected to be installed on your user’s system.

  • One solution is to prepare an installer that installs the redistributables (which your other users seemed to have done by some other software)
  • Another solution is to switch your project to link the runtime statically (setting in the Projucer)

At some point it was requested to use the shared runtime to save resources, but seemingly microsoft lifted that limitation, making it not so bad to switch back to the static linked runtime.

For further information have a look at this thread:

1 Like

i see… but how do i make an installer? is there a way to compile one with the projucer and visual studio or so? any tutorials on how vst installers work for juce plugins?

There is a tutorial on the juce homepage:

https://docs.juce.com/master/tutorial_app_plugin_packaging.html

The information of how exactly to include the runtime is a little brief, but I think googling for InnoSetup should get you further…

1 Like