Plugin Located in Folder with Company Name Via Installer


#1

Hi, I am making an installer for a plugin using a program called packages (http://s.sudre.free.fr/Software/documentation/Packages/en/Welcome.html). I have used this successfully to install my plugin in such a way that both VST and Audio Unit show up in any DAW on Mac. However, when the plug-ins are listed under company name folder in a DAW, mine is placed under the generic name yourcompany, which is somewhat unprofessional.

I am wondering how to make an installer in such a way that the plugin will show up in a folder with my company name in the DAW navigator. I have tried filling in all the information relevant to company or manufacturer name in the Projucer. I am installing the VST and AU files to

/Library/Audio/Plug-Ins/VST/myplugin.vst

and

/Library/Audio/Plug-Ins/Components/myplugin.component

respectively.

Thanks!


#2

You probably need to set the company name in ProJucer and rebuild. I don’t think this is related to the installer.


#3

As I said above, I have tried filling in all information relevant to company name or manufacturer in the Projucer. Sorry should not have abbreviated as jucer, will change!


#4

Could it possibly be a debug vs release build issue?


#5

Are you really sure you’ve filled in all the fields in the Projucer correctly and then resaved and recompiled your plug-in? I’d be astonished if this was a Projucer bug as no-one else has reported it and that bit of the code hasn’t change in ages.


#6

I think it was actually something with Ableton, since when I restarted my computer the plugin showed up in a folder with my company name.

Something really strange was happening where even after I deleted all copies (in both Root and Local Directories) of the plugin from my machine to test the install, Ableton would bring up an old version of the Audio Unit (while it would be unable to bring up the VST since the files did not exist). I guess Ableton was temporarily saving a version my AU plugin? Really, really weird. Restart fixed all that.

Anyway, everything seems to be working now within Ableton at least. I am experiencing another issue where the Audio Unit does not show up in Logic, which I have posted about here: AU Plugin Install Working for Ableton but Not Logic Pro X


#7

Wait, now the plugin is showing up in Logic when I create a new project but in the folder yourcompany and under an old name which I have long since changed in the Projucer Settings. Is it possible that Logic is storing a name for my plugin and not reading the new one?

I have changed project name, company name, bundle identifier, plugin name, plugin manufacturer, plugin manufacturer code, plugin code, plugin AU Export prefix, and binary name in Projucer settings.


#8

We’ve seen weird Logic behaviour like that before:

I think I remember other related discussions on this forum, but I can’t find them.


#9

When Logic is being weird there are two things to do…

  1. Either set your plugin version number to 0 or increment the version number. Logic uses the version number to determine if it should re-populate certain details they either expect it to increase or for you to set the version number to 0 during development - helpfully they don’t document this anywhere I only found out from contacting them after experiencing some issues in the past.

  2. I call auval -v x x x don’t ask me why, I guess because auval goes scanning for what it thinks is some new plugin, but it clears some cache that can sometimes be problematic - I find if I don’t do that the only other way to clear it is a restart!


#10

Thanks!

Plugin version being set to 0 caused the plugin to get recognized under it’s current name, though auval still recognizes the plugin as the old name as well, so now I have both in my audio unit folder in Logic, pointing to the same plugin.

Is there a way to remove a specific aufx entry using the auval command?


#11

First make sure you only have one on disk (i.e. have you still got one in the /Library and another in ~/Library). I would then try running auval -v x x x it will error but after doing so try auval -a again, is it gone?


#12

I tried running auval -v x x x, weird thing is that it succeeded in getting rid of the old name in the auval -a listing, but the old name still shows up in Logic. I also verified that I only have one copy on my computer at the moment, that in ~/Library.

I think this is some sort of memory that Logic Pro X is insisting on keeping, which is really weird.


#13

That’s annoying, OK…

delete

  • ~/Library/Caches/com.apple.audiounits.cache
  • ~/Library/Caches/AudioUnitCache/com.apple.audiounits.cache

Then log out and log back in again.

EDIT: You can also open Activity Monitor and kill both of the cprefsd processes – user and root, instead of logging out and in again.


#14

Okay, I’ve done that. Now I get an issue where I see two versions of the plugin the plugin manager with different version numbers, one of which crashes the AU test and one of which does not. I am certain I only have one version of the plugin on my computer so I am unsure what is causing this.


AU Plugin Install Working for Ableton but Not Logic Pro X
#15

I’m not sure why that would be, I would be tempted to remove all installations of your plugin - run all the above again and confirm no instances are found, then build the plugin again and see what happens.


#16

Are you loading up saved DAW sessions that have old versions of your plugin inserted into tracks? Some DAWs will cache bits of info about your plugin if you do this. If you open up a new project rather than a saved one do you still see the other versions? Every now and then I delete all my saved test sessions and start fresh to try and avoid this.