Plugin not showing up in Ableton/ AU

Hello everyone!

After following a workshop online to create plugins in Ableton with Juce I’ve tried to set up a new project of mine but it’s no showing up in the AU plugin section in Ableton. I’ve already tried to disabled and enable the AU and also to restart my computer, but I havent find a way to make a new plugin.
Im using the free version of Juce I don’t know if it’s because of that.
Any help would be really appreciated ! :slight_smile:

Thank you very much!

It’s sometimes difficult to get AU plugins to show up in hosts. These are the steps I normally try when a plugin isn’t showing up:

  1. Make sure that the plugin is actually installed. It should be in ~/Library/Audio/Plug-Ins/Components.
  2. If it is, run killall -9 AudioComponentRegistrar then auval -al from Terminal.app to rescan all AU plugins on the system. The plugin should show up in the output list after this.
  3. If the plugin still isn’t showing, you might need to change the characteristics of your plugin. Try changing the “Plugin Code” field in the projucer, then resaving + rebuilding the project. Then, try step 2 again.
1 Like

It worked, thanks!! :smiley: