Plugin won't load on Mojave

We’re building with the latest official Xcode (15.0.1) with MacOS 10.13 as the minimum target.

It seems like even with the legacy linker flag (see below) the plugin will fail to scan on MacOS Mojave (10.14) but work fine on Catalina.

The standalone app works fine on 10.14 as well, the problem is just with the plugin version and just on Mojave. Both auval, Ableton Live and Reaper fail the scanning with an error message kinda like “Not a plugin”.

We’re building using:


We’ve also added the flag:


Any ideas what this could mean?

Have you tried the AudioPluginHost? When you say plugin, which formats, is it all off them?

No, but I’ve tried Reaper, Ableton Live and auval, with VST3, VST2 and AU. All fail.

I didn’t try APH but I can certainly try to debug APH with this build plugin or a vanilla demo plugin if this helps find out what the issue is? It’s a bit hard to debug because my dev environment isn’t Mojave, I just have a testing environment like that (and it was also discovered on a user’s computer).

Update: This seems like it’s resolved by using the latest Xcode 15.1 beta and forcing use of the 14.2 SDK (the one in the beta) along with the legacy linker flags.

1 Like