Preferred naming for third party JUCE modules - juce_ prefix or not?

I was wondering if there was any preference, from the JUCE team or elsewhere, about how third party JUCE modules should be named?

Online I see a mixture, but quite a few named like juce_whatever - which reads nicely, but does it give the impression it’s an official JUCE module? Would they prefer e.g. author_juce_whatever?

I’m looking at releasing something soonish so wanted to try to decide on a name…

In my concerned i decided to use prefix_whatever with code namespaced accordingly (i.e. namespace prefix) to avoid to collide with JUCE. But i don’t know if it is the recommended approach.

I’m not sure why you would want to prefix with juce_? That would be confusing as a user: I would assume this module to be from the JUCE library!


Yeah I agree, I had just seen a few examples online which use that followed that structure. But yeah, I will use my own prefix!

Yep, I’d advise using some kind of prefix, but not juce_. The company or author name is probably a safe bet.

1 Like

Great, thanks for clearing that up!