Problem saving JuceDemo's Android Studio project


#1

Latest Tip - MSVS2013 - Win 7

{Emailing screen image, won’t upload 68KB jpeg :frowning: }


#2

When I try to save the JUCE demo project, I get the following message (Windows 8.1) :

An error occured while trying to save "JuceDemo" to the file : C:\SDK\juce4\examples\Demo\JuceDemo.jucer

Failed to create symlink from C:\SDK\juce4\examples\Demo\Builds\AndroidStudio\app\src\main\jni\Source\Main.cpp to C:\SDK\juce4\examples\Demo\Source\Main.cpp


#3

Android Studio on Windows needs to be abe to create symlinks in the build folder. Please run the Projucer with elevated priveledges (right click on the Projucer/Introjucer icon and select "Run as Administrator...") and re-save the project.


#4

Thanks, I'll try that. I'd never thought of it before, but is there a compiler switch to generate the .exe to Run as Admin (or an additional buld step to chmod it), or must it be a manual step every time it's (re-)built?

 

{Apols, being useless at the mo}


#5

Hi fabian,

I tried this on a different machine - This time on WIndows 10  (I'll re-try it on the original machine whe I get a chance) - No luck.

I Opened Introjucer as Administrator, and got the same problem.

{I can just delete the AdroidStudio section of the project}


#6

Ok! Doesn't fail now :)

I haven't tried to use the Android Studio project yet, though (though I have a lot of faith)


#7

Strange, I actually developed this feature on Windows 10, so it not working on there is quite the surprise! I'll look into this very soon, as we'd like to show off the Android Studio exporter at the JUCE summit.


#8

This issue is still there as of today (tried both with Projucer from Juce 4.2.4 and development branch).
The workaround “run as admin” works, but is not very obvious.

At least it would be nice to have it in the Android tutorial, as this tutorial might not work correctly otherwise under Windows and it takes some time to find this old thread as a solution…
Thanks!


#9

OK thank you! I’ll add it to the tutorial.