Projucer command line windows


#1

When I try to run the Projucer from the command line on Windows, it hangs after telling me it has:

Finished saving: Linux Makefile
Finished saving: Visual Studio 2015
Finished saving: Xcode (MacOSX)

No such problem on Linux, haven’t yet tried on OSX.

[edit] works fine on OSX too. Seems like a windows only problem.


#2

I don’t think it’s hung - just press a key and it should continue.

If you run the same command from a batch script then there will be no requirement for a key press.


#3

Thanks Tom. My instinct was to hit Ctrl+C once I saw it didn’t behave as it does on OSX. I tried calling the projucer with a simple Python build script, but it hangs. My Python script is pretty simple for now:

import subprocess
import sys
import os

pathToJucer = sys.argv[1];

createCabbageIDEProject = str(pathToJucer)+ " --resave ../../MyProject.jucer"
process = subprocess.Popen(createCabbageIDEProject, shell=True, stdout=subprocess.PIPE)

I’m sure the path to my project is correct as it works fine if I call it from the command line and hit a key after a few moments to finish. I would really like to be able to us a python script to build my apps as it involves quite a lot fo copied and rebuilding.


#4

I think you could call a batch script (which in turns calls the Projucer) from Python and it would work. You could generate the batch script on the fly, but clearly this isn’t an ideal solution.


#5

you are calling with shell=True, do you need that?
I think this will use cmd, whose default behaviour is to wait for a keystroke after finishing it’s process…
Maybe try again without shell or shell=False.


#6

Thanks guys. I’ll try out those suggestions. Creating a batch script on the fly should do fine. I only have to script it once. I’ll let you know if what @daniel suggested fixes it.