ProTools LE 8 win xp - mouse click + Alt button pressed


#1

Hi!
Just had a big search througth the forum, and can’t find anything similar:

I have JUCE rtas plugin (win xp, PT LE 8 )
and left mouse click with Alt key holdede down - works only once after plugin instantiation.
Closing \ opening UI - dosent help.
The same build for VST (windows) works ok, same build for PT mac osx works ok…
Could you please help.


#2

Have you tried it using today’s tip code?


#3

just downloaded latest tip -

RTAS enabled
win xp, visual studio 2008
after fixing
juce_PluginHostType.h line 136 : WCHAR* w = reinterpret_cast <const WCHAR*> (buffer.getData());

I have the following linker errors (after clean rebuild).

1>juce_RTAS_Wrapper.obj : error LNK2001: unresolved external symbol “class juce::String const __stdcall juce::operator+(class juce::String,class juce::String const &)” (??Hjuce@@YG?BVString@0@V10@ABV10@@Z)
1>juce_RTAS_Wrapper.obj : error LNK2001: unresolved external symbol “class juce::String const __stdcall juce::operator+(class juce::String,wchar_t const *)” (??Hjuce@@YG?BVString@0@V10@PB_W@Z)

so can’t try latetst tip with RTAS enabled.


#4

Sounds like you just need to do a really clean rebuild.


#5

Deleted all *.obj files by hand,
clean solution
rebuild solution

same linker errors


#6

Oh, it’ll be that damned digidesign __stdcall rubbish… Ok, I’ll check in a fix shortly…


#7

Thanks! =)


#8

Got latest tip, nothing chaged in RTAS / win xp (full clean), rebuilded andh checked two times.
alt + left click works only once after plugin instantiantion.

btw -
juce_PluginHostType.h line 136 : WCHAR* w = reinterpret_cast <const WCHAR*> (buffer.getData());

shouldn’t it be: WCHAR* w = reinterpret_cast <WCHAR*> (buffer.getData());


#9

I don’t have a win32 copy of pro-tools to debug with at the moment… When you say it only works once, do you mean that no further clicks get through at all, or that the alt key isn’t recognised any more? What about right-clicks?


#10

I mean that the alt key is not recognised any more.
Will try to check right-click…


#11

right-click works ok.


#12

In addition, somehow, AU and RTAS plugins (mac os x 10.5.6) are now (with yesterday tip ) working different in this situation -

If simple “about this program” splash screen is shown (with bool userPickedYes = aboutSplash->runModalLoop();
call), and if I want to close it - button on this component should be clicked 2 times in case of RTAS and 1 time in case of AU plugin.

here is the code -

class AboutSplash  : public Component, public ButtonListener
{
public:
	AboutSplash ();
	~AboutSplash();

	void paint (Graphics& g);
	void resized();
	void buttonClicked (Button* buttonThatWasClicked);
private:
	TextButton* textButton;
	Image* image;
}; 
//////////////////////////////

AboutSplash::AboutSplash ()
	: textButton (0),
	image (0)
{
	addAndMakeVisible (textButton = new TextButton (T("new button")));
	textButton->setConnectedEdges (Button::ConnectedOnLeft | Button::ConnectedOnRight | Button::ConnectedOnTop | Button::ConnectedOnBottom);
	textButton->addButtonListener (this);
	textButton->setColour (TextButton::buttonColourId, Colour (0xffffff));
	textButton->setColour (TextButton::textColourOnId, Colour (0x0));
	textButton->setColour (TextButton::textColourOffId, Colour (0x0));

	image = ImageCache::getFromMemory (resource::about_dark_png, resource::about_dark_pngSize);

	setSize (294, 258);
}

void AboutSplash::buttonClicked (Button* buttonThatWasClicked)
{
	if (buttonThatWasClicked == textButton)
	{
		exitModalState(1);
		this->setVisible(false);
	}
}

#13

You mean it needs to be clicked once to get focus before the other click is registered?


#14

I would say like the button itself is getting focus, not the splash screen component.
I have another one with two buttons (yes \ no), and if I click on “yes” and after that on “no” and after that on “yes” and after that on “no”… and so on - nothing happens =)


#15

You should setWantsKeyboardFocus (true) on the component, I think.


#16

Strange that it was Ok 3 months old tip, and it is Ok in AU… but anyway - thanks for a help, I’ll try it! =)


#17

Just tried setWantsKeyboardFocus, works the same.
Just noticed that something is wrong with mac RTAS plugin at all. Plugin does not receive any mouse movement data till first mouse click appears. And it is only in rtas build.


#18

Sorry, but may be someone else is using JUCE for macos rtas plugins?


#19

Well yes, lots of people are using it for that…


#20

Sorry for abusing you with such many questions, but should I wait for any movement on the subject (speaking about osx pt le 8 mouse handling in rtas plugins)? If you don’t have plans for this I’ll go to some older version. I would not ask it if the String class was not changed such, so it is not a 2 minutes to go back.
Thanks!

PS to be precise, I’ve not tried the latest changes (my tip is 2 days old ), sorry if I missed checkin with fix, I’m checking the git log every 2 hours…