Setting icon not working in iOS AUv3 mode

I made an audio plug-in, but after setting the big and small icon in Projucer and running on iPad, it still has no icon in AUv3 mode, the standalone app icon is showing correctly, but not the AUv3 one, any suggestions?

For my AUv3 builds, I’ve gotten used to having my Icon assets in the “Custom Xcassets Folder” setting rather than setting the Icon Small/Large fields. This makes sure my icons are bundled whether its in an AUv3 build or otherwise.

You might find it also worthwhile to set up the Images.xcassets folder for inclusion using this mechanism.

Thanks for the info, do you know which icon set juce is missing for AUv3? Like which icon set should I set additionally other than the juce set ones?

I just gave this a quick try by opening the AudioPluginDemo project in the Projucer, adding an icon and assigning it to the Icon Big and Icon Small fields, and then running the project on an iPad. After running the Standalone on the iPad, the AUv3 showed up in GarageBand with the correct icon.

If the icon isn’t showing up for you, perhaps there’s some caching or something going on. You could try completely removing the plugin and app from the device, ensuring that the icon is properly set in the Projucer, and then reinstalling the Standalone + AUv3.

Thanks for reply, I did delete my app on my device back then, but doesn’t work at all, so I switched to the Custom Xcassets Folder method and choose the folder JUCE created for me, then everything worked.

I can’t afford to try it now since the plugin is already published, but will try it in my next plugin, but really appreciated for the reply!

Hi, I just tried your method for setting my new plugin icon, still no icon for the AUv3 version on iOS just like before. Even in Xcode the icon won’t show up in scheme selector after set them in Projucer…

Update, I just changed my plugin name, and then the AUv3 icon just appeared! I’m assuming it might has something with the plugin name cache? I did changed the plugin name a few times before.

And just tried setting small&large icon method, still not working, but using the Custom Xcassets Folder method works.