Testing AUv3 on iOS - hosts can't find my synth or the JUCE example synth (SOLVED)


#1

Hi JUCE team,

I’m currently trying to test the AUv3 plugin on my iPad, but the host app “AUM” does not find my synth or the AUv3Synth from the JUCE examples.

I’ve uploaded both apps to itunes and started testing via TestFlight - downloading etc…
Note: IAA in my provisioning profile is enabled.
(EDIT: tried also by uploading to the iPad directly from X-Code)

My question - did you something magical to find or make the AU available for the host apps? Do I’ve to register it or something similar?

My plan was to try Apples example too (from here: https://developer.apple.com/library/ios/samplecode/AudioUnitV3Example/Introduction/Intro.html), but this is only for X-Code 7.3 or newer and I’ve running 7.21 on 10.10 :-/ Do you have an older example of Apples example somewhere in you lab - or do you know there to download it?

Thanks


#2

Is it possible that an iPad 3 is to old?


#3

Yes, you need an iPad 4, iPad Air or iPhone 5 (or newer, of course)…


#4

Thanks and Damn :wink:

But I found a old copy of the Apple AUv3 example here (for X-Code 7.21 or older): https://github.com/robovm/apple-ios-samples/tree/master/AudioUnitV3ExampleABasicAudioUnitExtensionandHostImplementation

Just change in SimplePlayerEngine.swift : “anyEffectDescription.componentType = kAudioUnitType_Effect” to “anyEffectDescription.componentType = kAudioUnitType_MusicDevice” if you like to list synths.

Problem solved: find my synth in the simulator and the JUCE one! Good work guys! :slight_smile: