Softtube VST3 plugins crash showing the editor


#1

Hey there - just letting your team know that when trying to show a SoftTube VST3 editor, it crashes the host. It crashes in the AudioPluginHost_App example with VST3 3.6.8 which is the latest supported VST3. I’m not sure if it is SoftTube’s problem or an issue with the JUCE VST3 plugin host code. Here is a link to one of their products that exhibits this behavior. https://www.softube.com/index.php?id=cc
There is a free 20 day trial with this plugin via Gobbler. Our testing shows that all their VST3s crash…VST2 is fine, though.

Thanks for your time!


#2

When you say “show” do you mean opening the UI? If so that could mean you’re destructing the sliders in your editor before you delete the slider attachments (the value tree state). I’d have a look there first.

Objects will delete in reverse order that they are declared, so be sure (in editor.h) that you’ve declared slider attachments AFTER the sliders (so they get destructed before the sliders do).

Hope that helps!


#3

Joshua,

Thanks for the reply! I meant that it crashes when showing the plugin’s UI. I am actually just using the JUCE demo VST3 host example. We use the VST3 hosting code in our DAW and through testing we found it crashes when loading any SoftTube VST3 plugin’s UI. So I tried the demo/example in the JUCE code and it also crashes…so its either a flaw in SoftTube or in the JUCE VST 3 hosting code.


#4

When you load in the host can you see where it crashes?


#5

It’s annoyingly hard to work out who’s at fault here - the Softube plug-ins don’t load if you have a debugger attached and even if you cover the JUCE code in print statements it’s difficult to see what’s going on.

One additional piece of info is that if you load the Classic Channel plug-in in REAPER then the interface is initially misaligned with REAPER’s window. There’s a large red box across the top of the GUI until you resize it.


#6

We’re crashing at

IPlugView* v = editController->createView (Vst::ViewType::kEditor);

#7

I found that if you load the SoftTube plugin and then attach the debugger, you can debug it. That sounds like the problem I am seeing - not sure if its a SoftTube issue or an issue in JUCE. Thanks for double checking this. (=


#8

Yes, but it would be nice to have the debugger attached when we’re loading the plug-in; createView is the first thing we call when displaying the editor, so something may be going wrong before that point.

I’ve sent a message to Softube support. Let’s see what they can tell us.


#9

Just a heads up that you left some DBG’ing in the commit:

Cheers,

Rail


#10

Yep, I was hoping no one would notice… :flushed: I didn’t mean to include juce_VST3PluginFormat.cpp in that commit. There’s a fix on its way but it’s held up in a busy session on our CI servers.


#11

Any update on the Softube issue. it still applies to VST2 and VST3 on OSX, AU is fine.
Did anyone contact Softube on the issue?


#12

I didn’t hear anything back :frowning: