[SOLVED] Develop and test for iOS 14.8 device doesn't work? Move to Xcode 13 already?


I was trying to build and test a Juce app (updated to Juce 6.1.2 master) for my iPad Air (3rd gen) that is on iOS 14.8, but when I connect my iPad, Xcode tells me “Xcode doesn’t support Koen’s iPad Air’s iOS 14.8 (18H17)”…

I’m currently on Xcode 12.4, and apparently the latest Xcode 12 is at 12.5.1, so I should probably update to that version, BUT from the release notes, it says: "Xcode 12.5.1 includes SDKs for iOS 14.5, iPadOS 14.5, tvOS 14.5, watchOS 7.4, and macOS Big Sur 11.3. " So: is this even going to help me at all?

Which version of Xcode actually supports iOS 14.8? Do I really need to update to Xcode 13, which was only just released 2 days ago (is that stable enough)?
Or should I just rename my current Xcode folder so I can keep it around and install Xcode 13 next to it?
Does anyone know if the Xcode 13 build has a DeviceSupport folder I could copy in Xcode 12, and does that work (I read on the interwebs that that’s how people have solved this kind of issue in the past for earlier versions)?
How do you do this? Is the Juce team working with Xcode 13 without issues right now?


You might be able to get it running by adding the missing SDK into Xcode 12.

Xcode 11 → 12 add some extra authentication or something so debugging iOS 14+ requires Xcode 12.
But… since it’s Xcode 12 I guess just adding the SDK would help.

1 Like

Thanks for the help, I had been looking at that but hadn’t seen a 14.8 DeviceSupport (was going to try and rename the latest 14.7.1).
But I actually first did the update to Xcode 12.5.1 by downloading the .xip file from Apple’s dev portal, and apparently that did the trick: I can now build and run for my iPad again.

Even now after installing Xcode 12.5.1, there is still no 14.8 folder in /Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/DeviceSupport (latest in there is 14.5) so I’m not sure why it does work now, but hey, it works…