[Solved] Unknown type name 'CarbonDummyPointName'


#1

Hi guys, I’ve been upgrading my code to the juce 5 master and I have the old CarbonDummyPointName workaround in my code which is causing this error. I’ve noticed that most of the usages of this workaround in juce were removed by Timur in early 2016. I haven’t been able to gather why they are no longer necessary though. When I try to remove it for my own code, the old ambiguous Point error comes back. I’ve tried a few things, building 32 and 64 bit, JUCE_SUPPORT_CARBON enabled and disabled. I’m using osx 10.11 sdk and deployment.

the old workaround in my code (used in a small mac helper module that I made, in a file called nam_MacHelper.mm):

#define Point CarbonDummyPointName
#define Component CarbonDummyCompName

#import <AppKit/AppKit.h>

#undef Point
#undef Component

... do stuff with NSView and friends ...


Thanks.

p.s.
Commits that removed the juce usages: (Note there’s still a usage in juce_audio_devices.cpp which if I remove doesn’t seem to cause a problem… maybe it was missed?)

Timur’s first commit: https://github.com/WeAreROLI/JUCE/commit/5ada47aa6fd1a980e19e077a6c65830e132c95c6

And the second one:
https://github.com/WeAreROLI/JUCE/commit/4c3ef3936d24ca5a0f0e6ce5c66e537c1929a291


#2

For anyone wondering, adding #define JUCE_CORE_INCLUDE_NATIVE_HEADERS 1 to my module’s .cpp fixed the issue.