[SOLVED] Win10 Release build can't be loaded on Win7

EDIT: I rewrite this completely since I got new findings:

If I build my plugin on Win10, it will not load on Win7 (“Error loading plugin”) on DAW startup. Another DAW will not see it at all.
This only happens with the Release build, Debug loads fine.
Also the version built on Win7 works on both systems.

Is there any way to get more information about what’s happening on the startup (mind that it’s a Release build with almost no output / symbols).

Ok I managed to start the DAW (Reason) via VisualStudio debugger and got the following output when it tried to load the plugin:

Microsoft C++ exception: NSBacteria::XOpen at memory location 0x0000000000403DF8.

So I guess my system is infected. Badum Tsssss…

On a more serious note: googling NSBacteria yields only this result on the JUCE forum, which seems to be related to Reason as well. But I can’t make the connection to my problem.

Anyone having any idea what NSBacteria is or what might be going on here?

Reading that thread it seems you are throwing some sort of exception that Reason is catching and then killing your plugin. Most other hosts would ignore the exception.

You might be able to add a breakpoint on exception throw and see what’s going on.

1 Like

I did so, but I have no pdb files for nothing here. This is the call stack and it tells me exactly nothing (note that I compiled the plugin in Release but with pdb symbols enabled)

grafik

I mean I could just use the Win7 Build (which works everywhere), but given the Win7 situation I most certainly don’t want to rely for future updates on a Win7 build machine…

Ok this is getting pretty weird:

I tried the same thing with the NoiseGate Tutorial and had the same result!

Could maybe someone be so nice as to try this on their machine?
Steps to reproduce are:

  • On Win10 export the NoiseGate Tutorial with Projucer 5.4.5 to VS2019
  • build VST2 in Release config (VST3 has the same problem as far as I’ve seen though)
  • On Win7 simply try to load the plugin in your host (I tried Reason and Bitwig)

Maybe the problem is still on my side, but if this were true this would most certainly be a critical bug!

Does installing the latest Visual C++ redistributables help? Maybe the Win10 builds use a newer Windows SDK version which isn’t supported on the Win7 machine?

2 Likes

YES it does! Thank you!

Weird though, since the latest VS19 was also installed on Win7.