Steinberg's DAW does not enable the ARA function

Hi, JUCE developers.

I am implementing a playback control synchronisation function in ARA in a plug-in currently under development.
The JUCE version is 7.0.1 and a VST3 plugin has been created and tested.

When we tested the system with DAWs, it worked as expected with Studio One5 and Reaper, but did not work well with Cubase12 Pro and Nuendo12.
All the above operation checks were done on Windows 10.

A sample project has been created to investigate the cause and is attached. (5.1 KB)

From my investigation it appears that the ARA function is not being performed on the Steinberg DAW because bindToDocumentControllerWithRoles() is not being called.
But, I cannot figure out whether it is an issue with my implementation, JUCE or Steinberg.
If anyone has any ideas, please advise.

Where did you install the ARA plugin?

C:\Program Files\Common Files\ARA

I tried moving to the path above, but it disappeared from the VSTi instrument list and could not be selected.
Of course, if I put it in “C:/Program Files/Common Files/ VST3” it will appear in the VSTi instrument list, but ARA will not be enabled.

You should be able to select the plugin via the menu Audio → Extensions. ARA plugins are not managed like standard plugins.


Thank you.
I can confirm that the plugin I created can be selected as ARA extension.

However, this way it is loaded as an extension to an audio event.
Am I correct in understanding that ARA-compatible plug-ins cannot be loaded as instrument tracks in Cubase or Nuendo?

1 Like

I don’t think ARA plugins have any way to do that (in any host). They’re intended as audio processing plugins, not MIDI instruments. (Ours allows MIDI in, but there is no way to use the ARA features to get MIDI data, only the audio source data.)


Ok, I see.
I misunderstood the ARA specification because the playback control part worked with MIDI instruments in Studio One and Reaper.
ARA is an extension for audio data, so it is not surprising that it cannot be used with MIDI instruments. I understood.