Stop Auto-scaling for Hi-Res screens


#1

Hello,

I have a vst that runs in a Juce host as a standalone app. On OSX retina screens, the host automatically scales to 2x, but we have 2x assets for this case that can be set in a user settings panel. This means the app shows up at 2x and 4x on Retina displays.

I’ve tried setting NSHighResolutionMagnifyAllowed: NO and High Resolution Capable: NO in the info.plist of the host, but it has no effect. I’ve also tried manually futzing with the masterScale values in juce_mac_Windowing.mm but I can’t get that to work predictably. It seems to be at a scale factor of 1 even though its definitely scaling to 2x on my laptop.

I’m also having the same issue with the PC build, but I haven’t even tried to fix that yet.

Any help is appreciated!

Thanks.


#2

Please try setting the master scale to 0.5.


#3

I tried that and it caused the window to appear a tiny fraction of the size, but the contents were still scaled to 2x, so I only see the top left corner of my app.


#4

That’s really strange. I’ll have a look at this. In the meantime you may want to try setting the scale factor via an affine transform on your top-level component.

myTopLevelComponent->setTransform (AffineTransform::scale (0.5f));