Synth1 GUI does not show in Plugin Host

#1

The GUI of the popular free synth plugin “Synth1” (http://www.geocities.jp/daichi1969/softsynth/#downmac) does not display in the Mac version of the JUCE Plugin Host. This error message appears 3 times in debug mode:

2019-03-15 10:27:45.412557-0400 AudioPluginHost[6986:108262] [com.roli.juce.pluginhost] CGContextDrawImage: invalid context 0x0. If you want to see the backtrace, please set CG_CONTEXT_SHOW_BACKTRACE environmental variable.

I’ve tried both AU and (Mac) VST2 versions of the plug-in, and in both cases I get a blank window. This is a Mac-only issue; the Windows versions of Plugin Host and Synth1 are unaffected. I’ve tried setting the environment variable as advised, but I find the resulting debug output incomprehensible.

I’m building a JUCE-based host application, and I also have this issue in stand-alone builds, but when I build my code as an AU plugin and run it in Logic Pro X, the Synth1 GUI displays fine, so there must be some kind of OpenGL setup missing in my code.

I read in Plugin With OpenGL UI Won't Run in Plugin Host? that a similar issue had been fixed in the Debug branch of JUCE, so I built the very latest Debug version of Plugin Host and it has exactly the same problem.

0 Likes