Tooltip issues


#1

Hi!

I've received a couple of error reports about tooltips that are shown only partially. Here's a screenshot:

Tooltip issues

Has anybody seen this? I cannot reproduce the problem myself and it seems related to certain graphic drivers. This specific plug-in was built with a fairly new version of JUCE (one or two months old), but it seems as if all our plug-ins are affected, which makes me believe it might be a JUCE issue...

Best,

Stian


#2

The link to your picture seems broken?


#3

I'm sorry. I linked to the file on KVR Audio and apparently you need to be signed in for it to display. Here's a another attempt:

Tooltip problem

Best,

Stian


#4

That looks like a problem we had some time ago where a bug in DirectWrite was giving the font zero height.. I thought I fixed it with a workaround, but you could try disabling JUCE_USE_DIRECTWRITE?


#5

Thanks, Jules! I'll try that.


#6

I just received feedback from one customer and disabling DirectWrite solved the issue for him (using onboard graphics, Asus Z97-K) so thanks for the tip, Jules. Do you remember when the fix was committed? The spesific plug-in was built with a version of JUCE from end of October.


#7

I think the fix was older than that, but it was only a hacky workaround for a mysterious DWrite bug, so can't guarantee it'd work on all OSes.