Unable to run Projucer on Ubuntu 15.10


#1

Hey!

 

I tried running the new Projucer from the free linux edition, and it fails with the error message "Illegal Instruction (core dumped)".  I'd be grateful for any help to get it running! I'm running Ubuntu 15.10 in Gnome 3.18 on an intel core i7-950, 6 GB RAM and an nvidia gtx 960.


#2

I'm experiencing same problem on lubuntu:

Processor       : 4x Intel(R) Core(TM) i5-3210M CPU @ 2.50GHz

Memory         :  5980MB (4744MB used)

Operating System     : Ubuntu 15.10

 


#3

Thanks for the report; we think we know what's going on and a new build should be out soon that fixes this problem.

Happy JUCEing!


#4

The Linux JUCE-ers appreciate it! (having the same issue >.>)


#5

Same Here. Should I change linux distru or wait?


#6

Our next build will fix this, but we're unlikely to release one for a couple of weeks.


#7

Awesome


#8

Hello. Hasn't this problem been fixed yet?

I am using Lubuntu, build 4.2.0-30-generic.

Getting the same "illegal instruction" message when executing projuicer.


#9

Sorry, we haven't updated the projucer build yet.


#10

Any idea on when to expect the fix?
And is it possible to get a previous stable version somehow?

Thanks!


#11

Update: i checked github repository - can you please tell me which version would work on my configuration? 4.0.3 or 4.0.2 probably?


#12

The projucer binary isn't in the repository. We'll release a new build of it at some point but don't have a date.

Are you talking about the introjucer? If so just build the latest version of that and it should work.


#13

Ok, thanks, i'll stick with this solution for now.


#14

Any update on this?

Today I tried with the current version on arch64 and Projucer is still throwing "Illegal Instruction".

Is it possible to use JUCE (and juce-projects) without the projucer?  Maybe with building the introjucer?  I haven't found any description for building from source.


#15

I have found the old arch build recipes and some rudimentary instructions on how to build introjucer from source:

git clone https://github.com/julianstorer/JUCE.git
cd JUCE/extras/Introjucer/Builds/Linux
make
./build/Introjucer

but I'm still searching for instructions on howto build the library.


#16

What library? The Projucer is a boutique frontend and is not needed to build or create JUCE projects. Once you've built the Introjucer, launch it and start creating your project. It will generate Linux makefiles for you that you can then use to build your projects.  


#17

The JUCE library. Or is it like I meanwhile suspect it to be, that the JUCE modules are built together with the application?

The tutorial on Pojucer states, that it is needed to create projects and build files for different IDEs:

Learn how to install JUCE. Create an Projucer project, and generate Xcode/Visual Studio projects that you can run and debug.

What do you mean by a boutique frontend? And in following the only available tutorials, the Projucer is the only frontend in the dowload package.

I'm missing a document where the function of projucer, introjucer and the library sourcecode and how it is used as a (prebuilt) library is described.


#18

I think there are some misconceptions here about how all that stuff actually works!

The JUCE library is not pre-built, it comes as source code. The Introjucer (or Projucer) is then used to create native Xcode/Visual studio/makefile/Android Studio projects set up in such a way that they compile all that necessary JUCE source code together with the source code of your app. It also employs some tricks to generate that project in such a way that it compiles relatively fast, the JUCE code is browseable, it has all the build settings JUCE needs, etc. So yeah it's definitely needed.


#19

I’ve just downloaded the last juce version from the site and I get this error on a 64-bit Ubuntu 14.04 LTS system.
Is there any fix for that?
Also are there any other alternatives?

Thanks.


#20

Did you make a new version of juce, cause i had this problem too