Verrrrrry newbie

projucer
tutorials
#1

Hi all,

I am starting coding on Linux and with projucer on Linux.
I downloaded the last version from JUCE and I have no problem to launch Projucer.
However, despite of the fact that I have Qtcreator installed (need to launch from terminal with qtcreator command line) save and open in IDE is not working…
As I did not want to bother you with this kind of message, I tried to find a message explaining how to declare Qt as my IDE or that I am missing dependencies… I could not find something clear.

I understand I might have misunderstood some basics…

Maybe there is some thread that I have to read first?
I read on some posts that on Linux, variety of configurations is so huge that no standard IDE is configured on projucer…
Well, at the end of the day, I am able to save a project and then of course I can open it manually on QtCreator… but I don’t know what to do next as Qt cannot compile a .jucer and the “build” button is grayed on Build menu.
Or maybe I am at the end of what I can do with projucer on Linux and then I have to make the next steps on Qtcreator??
Thanks in advance for your hints

#2

Note:
I am now trying to install the dependencies suggested here:


Actually, it doesn’t change the problem …

#4

Projucer on Linux (and to a degree on Windows and macOs too) exists just to generate the basic set up for your project. You need to compile the code with something else. The recommended way on Linux is to export the makefile and build from the command line. Maybe exporting to a Code::Blocks project can work. There is no exporter for Qt Creator/qmake.

#5

Many thanks!
Now this does make much more sense…
One more question: how could I have known this? I have obviously skipped this point and maybe some others… any recommendation of reading?

Thanks in advance

#6

Did you have a look at the official JUCE tutorials already? https://juce.com/learn/tutorials

#7

I think it unfortunately is so that the Juce tutorials skimp on the details on building on Linux as most users are expected to be working on Windows or macOs.

#8

There’s plenty of VST compatible Audio Hosts in Linux,


and CLion (beta) is in the list for Targets in Projucer and there’s a Ubuntu version of that.
First things first, does anyone know the best version of Ubuntu to use 14.02, 15.02, ???
As for compiler, is gcc or clang preferable?
VSCode is ported to Ubuntu for editing.
Thanks for any help to us Projucer Ubuntu experimenters.

#9

I think you need at least Ubuntu 16.04. You might prefer Ubuntu 18.04, which is the latest Long-Term Support (LTS) version.

#10

Btw. I had to add -no-pie flag on Ubuntu 18.04 otherwise all builds were identified as shared libraries not executables so couldn’t be run from a window. Probably it’s a bug in 18.04…

#11

I have 18.04 installed and it’s working great. However, Projucer makefile produces errors. Would like to interact with the devs to gets this nailed and working; Standalone and possibly Audacity plug-in.

#12

Hi,
thanks for all the ones who kindly replied.
Meanwhile, I made more trials and after some progress, I have now a kind of systematic issue when compiling with the makefile.
When all is almost done, I am getting this:

Compiling include_juce_osc.cpp
Linking NosciTest - Shared Code
Linking NosciTest - Standalone Plugin
/usr/bin/ld: build/nosci.a(include_juce_graphics_f817e147.o): undefined reference to symbol 'png_set_sBIT@@PNG16_0'
/usr/bin/ld: //usr/lib/x86_64-linux-gnu/libpng16.so.16: error adding symbols: DSO manquant dans la ligne de commande

And even a trial with a demo is no more working:

> Compiling include_juce_gui_basics.cpp
> Linking MultiTouchDemo - App
> /usr/bin/ld: build/intermediate/Debug/include_juce_graphics_f817e147.o: undefined reference to symbol 'png_set_sBIT@@PNG16_0'
> /usr/bin/ld: //usr/lib/x86_64-linux-gnu/libpng16.so.16: error adding symbols: DSO manquant dans la ligne de commande
> collect2: error: ld returned 1 exit status
> make: *** [Makefile:89: build/MultiTouchDemo] Error 1

I am actually trying to make plugin out of Faust.
I am very surprised because I had so far no problem to compile…
As usual, any help is welcome :slightly_smiling_face:

#13

@TMarqueyrol This is an issue related to the apt packages juce-modules-source and juce-tools.

Long answer: https://github.com/WeAreROLI/JUCE/issues/499#issuecomment-474590146
Short answer: get JUCE from the official source only (https://github.com/WeAreROLI/JUCE or https://shop.juce.com/get-juce)

#14

Thanks for your answer McMartin.
In deed, I got JUCE from the official source.
I tried to re-isntall my JUCE but this did not fix or changed anything…
I even forced to the original module (under that I have under home/JUCE/module and not usr/share/juce/module).
Any hint?
Thanks

#15

Hello again.
I might have found the issue.
After I removed all the files from my initial JUCE installation and removed the links that I had made to it, I re-installed from original .zip.
Now it does work again.
I experimented that when I opened from JUCE browser it worked, but when I opened directly by dble click on the .juce files it gave me a warning saying “deprecated version of PROJUCER”.
So I removed the link to projucer and now open from the projucer browser only.
But it is somehow strange to me…

#16

Spend some time learning git - you won’t regret it.

TL;DR:
Get JUCE directly from github: git pull origin master (or git pull origin develop):

git clone https://github.com/WeAreRoli/JUCE.git
cd JUCE
git checkout develop

and to update / reset any modifications you might have made:

git reset --hard
git pull origin develop