Vst host demo - lexical or preprocessor issue


#1

This is the next issue I’m encountering with the vst host demo after pulling in the most recent changes. I’m not certain that this is OSX/Xcode specific or not.

/Users/Ian/Cloud Services/Github/Juce (ianmclean)/modules/juce_audio_processors/juce_audio_processors.mm:26:10: In file included from /Users/Ian/Cloud Services/Github/Juce (ianmclean)/extras/audio plugin host/Builds/MacOSX/…/…/…/…/modules/juce_audio_processors/juce_audio_processors.mm:26:

/Users/Ian/Cloud Services/Github/Juce (ianmclean)/modules/juce_audio_processors/juce_audio_processors.cpp:85:10: In file included from /Users/Ian/Cloud Services/Github/Juce (ianmclean)/extras/audio plugin host/Builds/MacOSX/…/…/…/…/modules/juce_audio_processors/juce_audio_processors.cpp:85:

Much thanks.


#2

Those are just the lines showing the include context… What’s the actual error?


#3

Ok, I believe its this:

/Users/Ian/Cloud Services/Github/Juce (ianmclean)/modules/juce_audio_processors/format_types/juce_VSTPluginFormat.cpp:57:10: ‘pluginterfaces/vst2.x/aeffectx.h’ file not found

https://www.evernote.com/shard/s16/sh/34fd4e68-b59d-42d5-ac78-2d686197c4ed/8e97e1062c97235e3d75841a356ab525


#4

You need to include the VST SDK in an appropriate place, you can either set this manually in the Introjucer but I think it defaults to “~SDKs/”. Download the SDK from Steinberg and copy the “vstsdk2.4” directory into there.


#5

Ah, makes sense :slight_smile:

Thanks - giving it a shot.

I think this demo might benefit from the equivalent of “How to use this framework.txt” that the vst plugin project comes with (for those of us who have never done anything vst before). I think this is the only demo that requires a dependency that isn’t already provided if I’m not mistaken.


#6

you can either set this manually in the Introjucer but I think it defaults to “~SDKs/”

Actually I don’t see anywhere in the introjucer to set this.

I notice this in the code:

/* Obviously you’re going to need the Steinberg vstsdk2.4 folder in
your include path if you want to add VST support.

If you're not interested in VSTs, you can disable them by setting the
JUCE_PLUGINHOST_VST flag to 0.

*/

I’m just not sure how to add this to the include path properly. Placing vstsdk2.4 into ~SDKs didn’t do the trick unfortunately.


#7

Success. the vst sdk folder didn’t copy to ~/SDKs like I had thought.

Also found the path to be editable here for anyone else who may want to change this. See the image below.

Much thanks for your help guys.