VST not building on Mac 10.10 and Xcode 6.4


#1

My project builds fine in Xcode and a component file is generated in the Debug folder. However, no VST file is generated (again, there are no errors in the build). 

I saw a similar post when I googled around, but changing the wrapper extension to vst did not actually work when I tried to use that in Audacity. My VST folder is in the default place (~/SDKs/VST3 SDK). Anyone know why this might be happening? 

 

EDIT: Although the component file is generated, it is not working in Logic 9. On Linux, I was able to generate a .so file that worked as a VST in Tracktion (the only thing on Linux that runs VST3). The one difference I see between a working one I just downaloded and the one generated through JUCE is that the working one says Universal and the one that isn't says Intel (under Get Info). 


#2

Is the post build script copying the file to a folder which XCode has permission to. Copy to?

Rail


#3

I think so...the project folder is in my home directory and does not require authentication. Or were you referring to something else?


#4

So I found the solution from the Redwood Audio tutorial.

The files are not being written to /Library/Audio/Plug-ins/... they are being written to ~/Library...

The fix is to go into the terminal and type "chflags nohidden ~/Library". Now the library folder is under the user's main folder and the component file and both VSTs can be found. 


#5

I’m referring to the post build script that IntroJucer creates for your plugin XCode project which copies and renames the built plugin to your system user VST, AU, etc paths after it builds.

Rail