VST3 bypass not working in Wavelab 9


#1

The vst3 bypass code appears to be non-working in Wavelab 9 (on windows). Activating bypass just does nothing and the audio still goes through plugin processing normally. This is probably caused by a bug in the vst3 wrapper. Is anyone else getting this issue? It comes from one of my testers and I do not have access to wavelab 9.


#2

We were also experiencing this bug, but there is a fix on the develop branch of JUCE.


#3

Hi all,

I am beginner in JUCE development. I am currently trying to override the processBlockBypassed method to maintain latency compensation for my local Ring Buffer. This is working properly with VSThost but not with my plogue Bidule DAW.

So, as mentioned, I tried to use the tag 5.2.0 and also the current master branch of JUCE. After this too, my program flow never reaches the processBlockBypassed function.

Hence please clarify if there is any change in the implementation for checking the host Bypass status, after the above mentioned fix. Thank you very much in advance.

Regards
desbha


#4

Have you tried any other hosts?

It may be that Bidule just doesn’t support it.


#5

Yes, I have tried in Vsthosts by Hermann, the call back for processBlockBypassed is triggered in that host but currently we have Bidule as our standard host for our test environment. So only I would like to raise the concerns as there have been concerns about Logic Pro and I thought If it could help to check for other alternatives suchas using isBypassed() function in getStateInformation and setStateInformation