VST3 plugin installation - Windows 10


#1

Sorry, it’s very newbie question.
But for me it’s first time I’ve just built VST3 plugin on Windows 10, in Visual Studio 2017. Plugin is of course juce project. But Plugin Host Example doesn’t find my plugin. I don’t know how to install it?
With Mac Audio Unit it’s easy. It creates *.component file in project/build folder, and you can just move file to your plugins directory.

But for Windows VST3 in build folder there is created a lot of files which I don’t know how to use.

Please help.

For any help thanks in advance.
Best regards


#2

Assuming you’re using VS2017 and 64bit : In the Builds\VisualStudio2017\x64\ there will be Debug and/or Release folders, contained in there will be a VST3 folder, in which you’ll find My Awesome Plugin.vst3
Copy that to Program Files\Common Files\VST3 and you’ll be set.


#3

OK, thanks very much. But in my builds folder there is no such file as *.vst3.
There are only *.obj, *.log, *.lib, and *.pdb files


#4

If so, are you sure your build has succeeded?


#5

Yes I am sure that my build has succeeded. But I’ve just realized that in Visual Studio there are separated projects created for VST, VST3, and main source files project. I built only that main sources project. And it has succeeded.

But now I’ve just tried to rebuilt VST3 project and I get an error on line #include "pluginterfaces/vst2.x/vstfxstore.h" :

“Error C1083 Cannot open include file: ‘pluginterfaces/vst2.x/vstfxstore.h’: No such file or directory”

Do I need to install anything? Or just find that file somewhere and copy it to:
JuceLibraryCode\modules\juce_audio_plugin_client\VST3

???

And great thanks for your help in advance.


#6

Well, that’s “not succeeded” then. With version 5.4.0, JUCE stopped shipping the VST2-SDK, so you will be only able to create VST3 versions of your plug-in.

It seems, that you are using an already existing JUCE project, in that case, the JUCE_VST3_CAN_REPLACE_VST2 flag is enabled per default. That flag needs the VST2 SDK, which I guess you don’t have. You can disable that in the Projucer -> Modules -> juce_audio_plugin_client.


#7

Ha ha ha. Now it works.
Great thanks :slight_smile: