Want a successful RTAS compilation/build on mac


#1

Hi guys,

Seeing around the forum and only found there are threads about win rtas build. So I guess everyone is getting a nice rtas build on mac?

The au and vst builds are so straightforward and easy.

I am on osx 10.8 with xcode 4.4, with the latest juce_2_0_35. The audio plugin project is created by Introjucer and I have set all the paths. And I am using the PT_80_SDK.

Firstly, I got error in Digi’s sdk file:

#ifdef __GNUC__ && __POWERPC__
	#include <ppc_intrinsics.h>  // needed for __eieio
#endif

Of course I don’t have ppc headers I think. So I undef the POWERPC flag but the compilation still hits the include line…
So I comment the include statement out, like this.

#ifdef __GNUC__ && __POWERPC__
	//#include <ppc_intrinsics.h>  // needed for __eieio
#endif

Right after this, I got undeclared identifer ‘RegEntryID’ error in Dhm_Cards.h.

Dhm_MacObsDataMem(RegEntryID,		regEntryID)
	Dhm_MacObsDataMem(Ptr,				refCon[4])			// Ptr to info struct for PCI slot interrupt. 

	Dhm_StdDataMember(Dhm_Ptr,			quickReadAddr)		// Ptr to address for quick reads (AMCC workaround). 

	Dhm_MacObsDataMem(RegEntryID*,		regEntryIDArrayPtr)	// Ptr to an array of all of the regEntryIDs

The RegEntryID structs simply cannot be found.

How steps do you take to have a successful rtas build?

Thanks in advance.


#2

直接给他删了去!


#3

I’ve run the configuration shell provided by Digi, it did not help since it’s just a bunch of tools.

I cannot even compile the Digi’s PluginLibrary project right, with the same compilation errors.


#4

OK,
Use a 10.6.8 and the antique xcode 3.2.x, the Digi’s PluginLibrary and the juce rtas project can just build in a few clicks without any problem…


#5

I have exactly the same issues when trying to build an RTAS plugin...

Please let me know if there is another way to fix it, using MacOS X 10.9 and Xcode 5.1.1

Thanks !


#6

Find a way to download the MAC OS X 10.7 SDK, and use 10.7 SDK to build with RTAS' SDK.

I think the 10.7 SDK is the latest sdk that could work with rtas.


#7

Hi all,

I'm fairly new to Juce and also trying to get the Juce Demo Plug-in to build in RTAS format on Mac OS X. I'm using OS X 10.9 and XCode 5.1.1.

It fails at the linker stage with "library not found for -lPlugInLibrary". Where is this library located? Do I need to build the plug-in library myself using the XCode project in the RTAS SDK? I have tried (following advice on here) but cannot get it to build.

Any help gratefully received!

Thanks in advance,

Mark

 


#8

Hi Mark,

Yes, build the library yourself first… I’d suggest changing the compiler options to c++11 first… And then add the library to your project’s search path.

Cheers,

Rail


#9

Hi Rail,

Thanks for the reply. I've tried playing around with the compiler settings but no joy yet. 

The only SDKs available in XCode 5.1.1 are OS X 10.8 and OSX 10.9 - I saw somewhere that I need the OS X 10.7 SDK in order to compile the library - do you know if that's correct?

The screenshot here:  https://dl.dropboxusercontent.com/u/32917497/Screen%20Shot%202014-07-22%20at%2013.06.43.png shows the errors I am getting. I can hack my way around the fenv.h errors by removing a few of the preprocessor blocks, but I would prefer not to do that.

Cheers,

Mark


#10

You do need to install the 10.6 SDK inside the Xcode package… PM me if you need help getting this to work.

Cheers,

Rail