Xcode 4.3.2 "clang: error: linker command failed"


#1

Hello,
I am using Xcode 4.3.2 and 1.52 JUCE Library.

The flowing Error is occurring when building:

Build settings are:


NOTE: I tried building it with SDK 10.7 and Latest. Also I tried with both Apple LLMV compiler 3.1 & LLMV GCC 4.2.

The JUCE Library is linked as follows:

Any suggestions? Are any of the settings wrong?


#2

Well your project isn’t finding the libjucedebug.a file, make sure that in your ‘Build Settings’ the ‘Library Search Paths’ option has the directory of the library in it. I’m guessing it should look something like “$(JUCE_SOURCE)/bin”. Also make sure you have actually built the library and the files are there.

BUT, I wouldn’t recommend maintaining projects like that any more. 1.52 is a very old version of JUCE, there are lots of improvements and new features in the newer versions. I would get the tip and use the Introjucer to build and maintain your projects, it makes life a lot easier and you don’t have to worry about all those search paths. The procedure is explained here if you have Xcode 4 installed, you will already have Git.

Once you’ve got the tip, go to “juce/extras/Introjucer” open the Xcode project, build it and then you can use the Introjucer. Have look at the Jucedemo.jucer project to see how things work.