Xcode plugin processor.h errors

Getting hit with multiple errors when trying to compile Juce audio plugin framework…running Xcode V13. Any ideas on how to fix? Want to add that I’m new to coding as well.

Welcome to the forum!

The error you are seeing says, that the base class has no virtual methods e.g. releaseResources().
You probably wanted to inherit juce::AudioProcessor, but something went wrong.
We would need to see the first error message of the compiler.

Possible reasons:

  • trying to inherit AudioProcessor instead of juce::AudioProcessor (no type AudioProcessor, int assumed)
  • Didn’t include JuceHeader.h
  • circular includes

and others…

Thanks for the reply.

Here is the first error message starting from the top.

So it errors already when inheriting juce::AudioProcessor. Can you verify that your modules in the Projucer are actually found? Seems like the juce_audio_processors/juce_audio_processors.h is not found and probably the other headers as well.

You should also look at the compiler output, not only what’s printed in the source code. The reason is, because often those errors are follow up errors, which might be solved just by solving the first error (but not always of course).

Hey, apologies for the late reply. I’m checking the modules section on Projucer and it seems to be empty.

https://imgur.com/a/W9oQnLav

Here is a picture of it. When I click on rescan paths nothing happens either.

Three things you should check. First, are the paths set up correctly?


The modules section usually has some modules preselected, depending on which project type you chose. Ith the + button in the side bar you can add more modules, including your own custom modules using “Add module from specific location”:

I found the user path unusable. Theoretically you can select a different location for each module, but for the juce modules you shouldn’t mix modules from different versions. That is untested and sends you easily on a wild goose chase.

Good luck

Yes! This worked. Many thanks…