'PluginProcessor.h' file not found

Does anyone have any idea why I started to get this build error ?


This is the path in xcode to that file


The path in xcode to the file that cant find it is here



I tried this

(base) seans-Mac-Pro:Source seanwayland$ chmod 777 *.*
(base) seans-Mac-Pro:Source seanwayland$ ls -all
total 240
drwxr-xr-x  6 seanwayland  staff    204 Nov 22 13:47 .
drwxr-xr-x  7 seanwayland  staff    238 Nov 22 14:02 ..
-rwxrwxrwx@ 1 seanwayland  staff  50216 Nov 22 13:45 PluginEditor.cpp
-rwxrwxrwx@ 1 seanwayland  staff   3328 Nov 19 22:12 PluginEditor.h
-rwxrwxrwx@ 1 seanwayland  staff  50216 Nov 22 13:47 PluginProcessor.cpp
-rwxrwxrwx@ 1 seanwayland  staff   9356 Nov 20 21:55 PluginProcessor.h
(base) seans-Mac-Pro:Source seanwayland$ 

Didnt help

I tried deleting the file in XCODE and re adding it.
No Luck. I also tried renaming the file and renaming it in the includes. I tried creating a new projucer file.
That didnt help either.

Could it be a circular dependency issue?

I have no idea

I have the latest version of projucer and XCODE 10.1
Nothing changed as far as I know OSX sierra 10.13.6

I tried encoding all the files as UTF-8 in xcode. I also tried trashing xcode 10 and redownloading from the apple developer site. New projects created in projucer will not build.

not quite sure what you mean Kunz this happens with the boilerplate JUCE code spat out of projucer.

Eventually I tried downloading XCODE again.
No luck.
Redownloading JUCE FIXED IT !!!

From your initial screenshot, it appears that the code you have generated for your AudioProcessor, for some reason ended up being written to the file juce_AudioProcessor.cpp inside the JUCE source code, that’s where the base class AudioProcessor lives, and certainly that’s NOT where user code should be written.

Probably, re-downloading JUCE did restore juce_AudioProcessor.cpp to its original content, thus fixind the issue.

thanks it does look like I may have overwritten the juce library code !