AAX Plugin not shown


#1

Hi,

I'm building AAX release of an instrument plugin (let's call it XXXXX).

I'm going to describe what happens on Mac, but on Windows is pretty the same.

I'm using Juce 2.0. Starting from scratch using Introjucer, I can build a working (simple) 64bit plugin. Pro Tools 11 HD Developer Release warns me about missing signature, but when I create an instrument track I find my "AAX test plugin" in the insert list.

In the PT debug log I see:
 

CODE: SELECT ALL
168229488455,00c07,0e0d: Plug-In: AAX test plugin.aaxplugin, 1.0.0, /Library/Application Support/Avid/Audio/Plug-Ins/AAX test plugin.aaxplugin, 28/ago/2013 16:32.41



Now I build my real XXXXX plugin; the development started some time ago for other platforms, so I cannot start from scratch using Introjucer; anyway I tried to adapt the XCode project looking at the "AAX test plugin" project, setting all options, macros, and so on.

Pro Tools 11 HD Developer Release recognize the plugin at startup, it warns about missing signature exactly as the "AAX test plugin", but when I add an Instrument track, the plugin is not shown. I tried to change some build and link options but without success.

In the PT debug log I see:

CODE: SELECT ALL
168229893371,00c07,0e0d: Sys_DLLMacOS::LoadBundle "XXXXX.aaxplugin" has arch 16777223 ( need 16777223 ).
168229908351,00c07,0e0d: Plug-In: XXXXX.aaxplugin, 1.0.0, /Library/Application Support/Avid/Audio/Plug-Ins/XXXXX.aaxplugin, 28/ago/2013 17:10.07



Does anyone could give me some hints? Why the plugin is recognized at startup but not shown in the insert list? Where I can start looking?


#2

You have to use a Dev build if you haven't signed your plugin...  Refer to the Avid Dev forum for additional details

 

Rail


#3

Hi all,

here how I solved.

AAX wants also mono configuration and wants that the plugin declares the number of audio input channels, even if I do not use them (as it is a generator).

So in my Juce configuration now I have:

#define JucePlugin_MaxNumInputChannels 2
#define JucePlugin_MaxNumOutputChannels 2
#define JucePlugin_PreferredChannelConfigurations {1, 1}, {2, 2}

while before it was:

#define JucePlugin_MaxNumInputChannels 0
#define JucePlugin_MaxNumOutputChannels 2
#define JucePlugin_PreferredChannelConfigurations {2, 2}


#4

Hi Rail,

as I wrote, I used the Developer Build (I called it Developer Release); the point was not the signature, I know about it.

The problem was that the plugin did not get listed; anyway, as I wrote few minutes ago, I solved.

Best

Emanuele