Application can't be Launched

gui
projucer

#1

Hi all,

Another Juce Noob here having issues. Literally only started creating a project today.

I have just started the tutorial:
Create a basic Audio/MIDI plugin, Part 2: Coding your plug-in.
https://docs.juce.com/master/tutorial_code_basic_plugin.html#tutorial_code_basic_plugin_gui_control

I am stuck at the step for ‘Create a simple GUI control’.
At this stage I should be able to compile in the code in the JUCE host editor and see a GUI window open with a vertical slider.
However, the ‘play’ button beside the Xcode icon (my IDE) is shaded out and hovering over it gives a tag that says “Application can’t be launched”. Command + B also does nothing. There are no other errors or warnings in Projucer.

This means I cannot proceed to the next step.

I have run examples without issue and have completed another tutorial, the MainComponentTutorial:
https://docs.juce.com/master/tutorial_main_component.html
This compiled and ran fine in Projucer.

I’m running JUCE v5.3.2 on OSX10.12.6

Any ideas what is wrong here?
I’m sure it is something simple that I’m just not aware of.
Any advice at all would be much appreciated.
Thank you in advance.

D.


#2

Did you check the stand alone application build is enabled in the Projucer? If that is OK, you will also need to set Xcode to build and run the stand alone application, it may be set to for example “shared code”, “VST plugin” or “AU plugin” by default.


#3

Hi Xenakios,

Thanks for the reply!
As I said in my initial post, I’m a complete noob to this, so thank you for your patience.

I’m looking for some way of seeing what my build options are, or where they are.
In the drop down ‘build’ tab there’s nothing that brings me to settings related to enabling stand alone application building. Also all the ‘gear wheel’ setting tabs in other areas of Projucer don’t seem to have anything relating to enabling stand alone application builds. But again, I could be missing something.

In Xcode it was indeed set to “shared code” by default, but again there is no option for stand alone application. The is a check box for “All”, but that is shaded out and uncheckable. Should I enable all?

Again thank you for your reply, patience and time.

D.


#4

In Projucer :

Note that you have to resave the project again as an Xcode project for the additional build options to come into effect.


#5

Hi Xenakios,

Thank you so much for that.
I had an idea I had overlooked something when searching through.

It has compiled and saved fine in Xcode now and there is a stand alone .app version of the file in the build folder.
However, the ‘play’ icon is still shaded out in Projucer. Which is odd.
I have shut both applications down and reopened and still no change.

But at least now I can test the GUI via the stand alone version. So I can progress through the tutorial. Maybe there’s something missing right now that later on in the tutorial will be added, and that might change things.

Again thank you for your help I really appreciate it.

D.


#6

You really probably want to be doing your real development in Xcode anyway. (Just use Projucer to generate the Xcode projects.)


#7

You need to select the standalone app as your target in xcode via the target popup menu. Then the play button will work:


#8

Hi Fabian,

Thank you for that!
I have selected Stand Alone Plugin in the bar you have highlighted.
The GUI is now opening up when I run/build in Xcode. Which is an improvement.
However, the play icon is still shaded so the GUI cannot be launched via Projucer.
As per Xenakios suggestion I am focusing on doing all of the editing in Xcode and using Projucer to set up and generate the Xcode projects.

Thank you again for your help!

D.