ARA Plugin Demo not playing back audio


tldr: can’t get audio to playback when pressing play in DAW from my ARA plugin based on the ARAPluginDemo

i’m currently trying to get a project working with ARA and JUCE. I’ve been building the ARAPluginDemo provided by the projucer. when building this project as a VST or as an AU on mac I can’t seem to get audio to playback in reaper. let me detail the steps i’m taking:

  1. create a new project in juce using the ARAPluginDemo
  2. open the project in XCode
  3. build the project (as a VST or as an AU, i’ve tried both)
  4. load in audio in my DAW (Reaper or Logic)
  5. scan for the newly built plugin
  6. apply the plugin to a track of audio
  • when using the VST version i get the ARAPluginDemo UI and i can click on the waveform to play back small regions of audio; however, when i hit play in the plugin or in my DAW no audio is played back or sent to the master track
  • when using AU i get an error stating that “ARA is not detected”

has anyone else run into this issue?

here’s the details of my computer and software:
MacOS: 13.0 (22A380) M1
Reaper: v6.75
ARA_SDK: releases/2.2.0
CMake: 3.25.2
JUCE commit: 9f6432544

thanks for any help :)

AudioUnit - ARA plug-ins are not supported by Reaper. In fact, I think that AudioUnit - ARA plug-ins are only supported by Logic.

1 Like

The JUCE ARA plug-in demo doesn’t support resampling, if the sample rate of your audio region differs from the project sample rate, the plug-in won’t render anything. Ensure that the sample rate of your audio region matches the sample rate of the project.


Have you tried running Reaper in Rosetta on your ARM Mac?

The demo from my testing don’t do resampling or even mapping, so make sure you have 1:1 with sample rate of audio source and track width (number of channels) or you’ll get silence…

thanks for the advice!

i made sure that the project and the piece of audio both have the same sample rates and i’m still running into the issue, any other ideas?

ya i’ve tried this too and the results are the same

small update i’ve also tested this on windows and i get the same issue

As @ttg noticed, the problem may also be related to the number of channels.

When you load the audio file on the track, the audio region should appear on the graphical interface of the plug-in, is this the case?
Now by clicking directly on the audio region in the plug-in, it should play a small loop of the audio region, is this the case?
If so, it is probably a problem either related to the sample rate or the number of channels. The management of the sample rate can be a bit tricky in Reaper, there is the one of the global settings of the software, the one of the document.

Finally, by debugging the plugin you should be able to see what is happening in the process :wink: