AudioPluginDemo, no sound in GarageBand (iOS)

I’m currently working on the iOS version of my plugin and found out it doesn’t work in GarageBand (but works fine in AUM for example). So tried the good ol’ AudioPluginDemo to see if I was doing something wrong, but same happens for it. Editor opens fine, but no sound.


Just checked again today with latest develop tip but got the same result. Actually, the AudioPluginDemo doesn’t even work anymore here in AUM. Editor seems frozen (the MidiKeyboardComponent doesn’t react to touch events). Any clue?

So from looking into this it seems that GarageBand disables output for aumu AUv3s if they have an input bus. As far as I can tell we aren’t doing anything wrong in the AUv3 wrapper and this is only an issue with GarageBand as AUM loads an aumu with an input bus correctly and it outputs sound. This commit has updated the AudioPluginDemo example to remove its input bus as it wasn’t doing anything anway, so the example should now function correctly in GarageBand. I can’t reproduce the frozen editor issue in AUM though - which version of iOS and AUM are you using?

1 Like

OK, I’ve partially reverted the previous commit to add back in the input busses to the AudioPluginDemo as it can also function as an effect plug-in. If you need to test a pure instrument plug-in, then there is the AUv3SynthPluginDemo in the examples directory which will work in GarageBand.

1 Like

Thanks a lot for your help, Ed. Appreciate it.