AUResources.r missing


#1

I am running OS X 10.9.4 (a clean install) and Xcode 5.1.1. I have installed the latest JUCE from GitHub and tried to build the example 'audio plugin demo' which fails on Rez being unable to find AUResources/AUResources.r  referenced in juce_AU_Resources.r.

I tried installing Xcode 4.2 as it appears that might include the AU headers, but the OS says I may not install such an old version.  I have installed Audiotools for Xcode 4.4 which has also not helped.

How can I get the CoreAudio header files into the SDKs folder?


#2

This page helps: http://hoxtonowl.com/forums/topic/audiounits-compilation-tips/

download the sample from http://developer.apple.com/library/ios/#samplecode/CoreAudioUtilityClasses/

Move the CoreAudio folder to: /Library/Developer/CoreAudio

create a symb. link from /Applications/Xcode.app/Contents/Developer/Extras/

In my case Extras did not exist so

cd /Applications/Xcode.app/Contents/Developer/

sudo mkdir Extras

cd Extras

sudo ln -s /Library/Developer/CoreAudio CoreAudio

check in XCode that "Juce Library Code"->"Juce AU Wrapper" files are found and not red

now it's possible to compile the AU

for vst3 vst:

Go to Steinberg.net register as developer and download the vst3 SDK

copy the "VST3 SDK" Folder to /User/<your username>/SDKs/     (create folder SDKs...)

next you need the vstsdk2.4 which isn't available on steinbergs site

I found it here -> https://github.com/aardvarkk/soundfind

download it and copy the vstsdk2.4 folder to /User/<your username>/SDKs/

now XCode throws a couple of errors in the audioeffect.cpp and other files just accept the compiler casts.

my last error was that there was no VST3 Dir at /User/<your username>/Library/Audio/Plug-Ins/

create the dir and tata! it works

testet in Ableton Live....

hope this helps...

would be nice if someone adds this to the "How to use this Framework.txt" in the audio plugin demo project ;-)

 


#3

wow thanks a lot on this one!!! :D I guess this thread should be renamed to "Compiling JUCE audio plugins on OSX 10.9.4"


#4

Updated my XCode this week to 6.0.1 - you need to recreate the symbolic link and the "Extras" directory.