Automation not working in Ableton and Studio One with GUI open


#1

Hello,
I’m just putting the finishing touches to my first plugin and am testing it on different systems. It loads in logic x and studio one 3 but for some reason can’t be seen in ableton. Does anyone know why this could be? Also, I am having issues with studio one automation, it only updates the audio parameters in my plugin when playback stops, does anyone know why this is as logic works perfectly?
Thanks.

Edit: problem solved with plugin not appearing. Automation however doesn’t work in studio one and ableton when the GUI is open.


#2

If you go to Live->Preferences->File/Folder and then turn “Use Audio Units” and/or “Use VST Plug-in System Folders” off and then on again, does it show up then? Live can be finicky about refreshing the plug-in list on occasion.


#3

Thanks, I noticed on one of my tests that I was running 32-bit live. Upgraded to 64-bit and the plugin does appear (could have just worked because it reset). It does have an issue like studio one though… When the GUI is loaded, automation doesn’t appear to work very well. Live even turns its automation off! Any idea what could be causing that?


#4

Sounds like your editor is setting the processor’s parameters constantly. Might want to look at what’s going on in your listener/timer callbacks.


#5

All I’m doing is updating sliders. I set all of them to dontSendNotification and got no change.

Edit: Thanks, this was actually the solution, I missed some of the parameters by accident.