'base/source/baseiids.cpp' file not found


#1

Hi everyone,

I was hoping someone can provide some kind of a tip to fix the error: ‘base/source/baseiids.cpp’ file not found, which I get when compiling the audio plugin host example (on Windows 10 64bit). The error remains after checking:

The VST SDK path is set correctly (the path is not turning to red text)
Resaving the project after setting the VST SDK path
I tried VST SDK 366 and 367
Enabling VST3 only in the juce_audio_processors component

Anyone ideas how to fix this error?


#2

The most important info would be, which version of ProJucer…? If it is before a certain timepoint (somewhere in 4.3.1 in develop, and definitely in master before that), than it will work with VST <= 3.6.5, otherwise with >=3.6.7 (3.6.6 IIRC was an unlucky on, you might want to avoid).

See here:


#3

Thanks Daniel,
I got the plugin host exampole project compiled without errors :grin:


#4

hmmm…

It seems the compile went only ok when JUCE_PLUGINHOST_VST is enabled and JUCE_PLUGINHOST_VST3 is disabled.

Is this supposed be correct?

Note, I’m using Projucer 5 with VST3 SDK 367


#5

sorry, I didn’t experiment with hosting yet, it’s on my wishlist.
Hopefully somebody else can chime in…


#6

I’m not sure what’s going wrong here. We’ve not had any other reports of VST3 hosting not working so I expect it’s a configuration problem rather than a bug. Sorry I can’t be more helpful!


#7

ok no problem. I’ll skip it for now and will try the savihost tool or otherwise just a sequencer for testing VST plugins


#8

I’ve been getting the same error. Currently running MacOS Sierra, Projucer 5, Xcode 8.3.2. Most recent Steinberg SDK has been downloaded and placed. My build fails in Xcode and Projucer and states ‘base/source/baseiids.cpp’ file not found. But it is clearly there. I would definitely consider myself a beginner in this realm but feel I’m missing something pretty basic. Any thoughts/words are welcome!


#9

Placing the SDK in the JUCE directory will only solve this problem if the JUCE directory is in the compiler include search paths.

Put the SDK somewhere more convenient and add the path to it to your Projucer project. You can do this via the Projucer -> Preferences -> Paths menu or, for a specific exporter configuration or the live build, adding it to the “Header search paths” field (accessible by clicking on the gear icon for the live build).


#10

Thanks for your help @t0m ! This is my first forray into this world. “Hello world” mode :joy: Know that you made a newbie’s day!


#11

Has anyone solved this problem already?
I have the same problem, using Projucer 5.0.1 and VST 3.6.7.


#12

Yes - if you read the previous posts then all the info is there, though it might be scattered around a bit.

In short: if you’re seeing ‘base/source/baseiids.cpp’ file not found, then you need to add the path to the VST3 SDK to the header include paths of the exporter you’re using or, if you’re using the live build, the live build settings.


#14

Thank you very much Tom. That helped. I’ve read all the comments but didn’t quite get the message. Thanks for the summary.


#15

We’ve tried adding a big comment in the source file above that include statement that explains what you need to do, but frustratingly people don’t seem to ever bother actually looking at the line of code where the error happened, they just read the error text and come on here to ask about it…

However, there’s a new C++ trick in the latest compilers called __has_include which we might be able to use to throw up our own special error message when people fail to a particular header file available, and that might help to avoid some confusion! We’ll investigate that at some point.


#16

Hi,

Thanks for your comments - but I still seem to miss something…

When opening ‘…/JUCE/examples/audio plugin host/Plugin Host.jucer’ on my Mac in the projucer I get the following error:

'base/source/baseiids.cpp' file not found

When pushing on the [Save and Open in IDE] button, however, no error is shown and, after compilation, the ‘Plugin Host’ starts up without any problem.

Opening the preference page via “Projucer > Preferences…” the following path is shown for VST3 SDK:

~/SDKs/VST3 SDK

The file baseiids.cpp is here:

~/SDKs/VST3 SDK/base/source/baseiids.cpp

In the “Exporter Settings” for Xcode the attribute “VST3 SDK Folder” has the value:

~/SDKs/VST3 SDK

Any idea what is going wrong?

Thanks for you help,

Dietrich


#17

Hi Dietrich,

In global search paths (in the Projucer dropdown), there are two sections, Modules and SDKs.

Under SDKs, you will see VST3 SDK.

Your entered path should be to the top level folder of the SDK, similar to -

/Users/dietrich/Documents/SDKs/VST_SDK/VST3_SDK


#18

It looks like the Projucer live build isn’t picking up the SDK paths.

To work around this just add ~/SDKs/VST3 SDK to the live build settings under “System header paths”. You can get to the live build settings by clicking on the gear icon near the bottom.


#19

Hi Tom,

After adding “~/SDKs/VST3 SDK” to the live build settings under “System header paths” the live building system works.

Thank you very much for your help!

Dietrich

PS: I suppose that the examples should work out of the box. Therefore the exporter settings and the Projucer live build system probably should use the path defined under “Projucer > Preferences > Paths > VST3 SDK” by default. The first works, the second not, so this probably is a bug. Is there a bug tracker where I should post this - or is this message enough?


#20

Hi Anoesisaudio,

I actually did that already (as I tried to describe in my first posting) - but it didn’t work. The solution was to add the path under the live build settings under “System header paths” as described by Tom in the next posting.

Thanks for your help!

Dietrich


#21

That message is enough - we’ll fix it.