Can JUCE5 compile by vs2010 or vs2005?


#1

Can JUCE5 compile by vs2010 or vs2005,thanks.


#2

Sorry, not any more. VS2013 or later for JUCE 5.


#3

You have to give Avid some time to catch up, before you can also cut vs2013:

It’s only 4 years behind… :wink:


#4

Is that documented somewhere? That’s quite an important property of a framework.


#5

^this absolutely. I’ve seen people say VS back to 2010 is supported and that was my impression at first (though with some research that doesn’t make sense since C++17 is in JUCE now) but I haven’t seen it featured prominently anywhere.