Can not build with Projucer 4.2 in OS X Yosemite


#1

Dear all,

I could not build the Hello World example during 4.2 version testing. I did not have this problem with 4.1,

I am new at JUCE programming, so any suggestions?

Here is the error message in the build section. There was no solution while restarting the compiler. It brings the message over and over again and I can´t find the error.

Regards…

Ariel.


#2

This is a known bug and a duplicate of the one reported here
I am working on a fix.


#3

+1 I’m seeing this too when building the demo projects in the Projucer and it didn’t go away after updating to El Capitan.


#4

Wow, this bug took forever to track down!

It’s fixed now. You can update to the newest tip and re-build the Projucer. If you have the DLL (JUCECompileEngine.dylib), you should now be able to live-build again with that Projucer.

The fix will also be rolled out to the website download version as soon as possible (not today though, that process unfortunately takes a bit longer).


How to update Midi Device
#5

Is there a way to change the path to JUCECompileEngine.dylib in projucer?


#6

Ok I found a fix. The dll for osx should go in ~/Library/Application Support/Projucer or /Library/Application Support/Projucer. Then make sure to copy and paste the projucer app on the desktop and open from there. This worked for me on OSX 10.11.4.

You can also change the path in projucer_CompileEngineDLL.h

Is there a way to have a separate installer for the dll? That way it’s in the correct folder the projucer app is looking for or have us be able to change the path under Tools->Global Preferences?


#7

There are a number of locations where the dll will be found automatically. It can be:
* in the same folder as the Projucer.app, or
* inside the Projucer.app bundle, or
* in /Library/Application Support/Projucer, or
* in /Users/yourname/Library/Application Support/Projucer
So there is no need to introduce another setting or an installer. Just make sure the dylib is in any of those locations (in the download version of JUCE it is inside the Projucer.app bundle).


#8

Yeah I tried it by default and it didn’t work. But I’m glad to get it working.
Thanks!