Can't build Projucer on VS2017/SDK 8.1/Windows 7


#1

As described in the title.

Error MSB8036 The Windows SDK version 10.0.14393.0 was not found.

Is it intentional that the Projucer can no longer be built without Windows 10/SDK 10?

edit : I was able to hack around this by modifying Projucer’s own .jucer project and resaving the VS project…But not ideal to do it this way.


#2

10.0.14393.0 is now the default for VS exporters but you should be able to change this in Visual Studio under Project->Properties…->Windows SDK Version.

For projects saved with the Projucer you can change the SDK version in the “Windows Target Platform” dropdown of the VS exporter settings:


#3

I have the same problem.
What if we want to target the project to windows 7 platform and it is not on the list?


#4

Hey guys, I have the same problem. The thing is that I am just not able to build Projucer at all. It says 10.0.15063.0 is missing and that I should retarget. Well, I do have 10.0.16299.0, but retargeting to this one doesn’t help and it still complains about 15063 missing (which of course is missing).

Any ideas?

I guess I could install VS2015 and build Projucer using that one, but that’s kind of overhead…

//edit: I should have probably stated it’s VS2017 community and I have also tried installing the newest updates of the VS.


#5

Are you using the latest tip of the develop branch? The VS2017 project should be using the 16.0.16299.0 SDK by default, not 10.0.15063.0.

However, sometimes installing the latest updates in VS doesn’t install the latest SDK, so you may need to open the installer (usually located in C:\Program Files (x86)\Microsoft Visual Studio\Installer), click “modify” under “Visual Studio Community 2017”, then untick and re-select the 10.0.16299.0 SDK under “Individual Components”->“SDKs, libraries, and frameworks”.


#6

Yes, I have pulled the last version. However, thinking about it, that sounds just about right… There might be some merge problems since even retargeting the solution still complains about 15063 which shouldn’t be there at all… I will check that and let you know.


#7

OK, the problem was I was not on the develop branch but rather on the latest tip on the master which hasn’t been updated for quite a while. This still doesn’t explain why it would still complain about missing SDK even after retargeting but it works so I guess that’s enough.

Thanks

BTW what happened with all the ButtonListener, ValueListener and other *Listener shortcuts? It seems I cannot use them after the update. Were those removed intentionally, or do I miss something? Well, it’s not a big deal but I still like to know…


#8

ButtonListener, ValueListener and other *Listener were workarounds for a very old Visual Studio (VC6). Nowadays, you should use Button::Listener, Value::Listener and *::Listener. See the commit where @jules got rid of them: https://github.com/WeAreROLI/JUCE/commit/a7e3339f86e8dd9979857d5b163d530a2cfa7014


#9

OK, thanks.