Demo Plugin (Windows 64bit vST) won't load in Ableton


#1

I successfully compiled the demo plugin in the VST format, as both a 32-bit and 64-bit plugin. The 32-bit plugin loads in ableton 32-bit, and the 64-bit plugin will load in savihost… but refuses to show up in ableton 64-bit’s plugins list…

I selected 64 bit in the architecture selector in the exporter on the config panel… on both the debug and the release version. What could the problem be?

PS: I also can’t get the plugin to load AT ALL when i compile on mac… but that can be a problem for another thread


#2

This usually has to do with the “Mac OS X deployment target” setting. Make sure it’s equal or lower to the OS X version you are running on.


#3

This is odd? Are you sure you are compiling 64-bit? Did you change the architecture to 64-bit in the .jucer file AND within VS2015 (see screenshots below).


#4

Yes,64 bit is selected in both. But FYI I am using VS 2010, not 2015… I was never able to get the projects to open in VS 2015 for some reason


#5

Just tried changing the deployment target on the mac version… it’s set to 10.10 (yosemite) in all places… config panel in projucer, and in Xcode. no errors during build but still won’t show up in the plugins list!


#6

ok… just got 64 bit windows version to load in ableton! somehow, changing the file name worked… i think ableton just decided to start ignoring it when it didnt load the first time, or something…

I still can’t get it to load the build from xcode on mac though… im assuming there’s not a way to make a mac version on pc, correct?


#7

Nice, had the same problem only with a 32bit VST. Just renaming the VST helped.