Windows is driving me crazy (W10Pro + VS2015)


#1

Hi guys,

I'm facing a really WEIRD issue. I just got a new laptop, with W10 Pro and Developer mode enabled, and moved all my stuff from a VM with Windows 7 Pro. Same projects, same files, same Visual Studio... I can compile without errors, but once I try to load the VST2 .dll file in Ableton 9.6 I get an error message about the VST not being compatible with Ableton Live. I don't know if I missed something while reinstalling VS2015... the demo plugin compiles and runs smoothly, so I'm basically clueless here. Anybody experienced something similar?

Thanks!

 

UPDATE: I tried compiling the same project on the VM (which this morning I updated to W10Pro too).. well, turns out that the same project which was working until yesterday now shows the same issues as above.. compiles successuflly, but the plugin is not compatible.


#2

Check the platform toolset settings. I'm not at my pc at the moment, but can look up my settings for you later if you like. 


#3

Hi Andrew,

already done.. they are just the same as before (v140). I suspect that, in a very weird way, AAX version is getting built even if is disabled. I run this test on the VM: disabling VST, enabling AAX, building again, disabling AAX, enabling VST, building again -> success.

I'm wondering if I can build just one single dll for both... the entry points should be different, so it wouldn't be a problem.

Cheers.


#4

- make sure you're doing x32 -> 32 bit host or 64 to 64bit host. (I guess you already checked, but re-checking might help)

- remember that there's batch script at the end of the build simply copying the file to multiple files/folders so you might get aaxplugin / dpm even if you've got them unchecked on your jucer project.

- if you're switching from an older machine I'd also suggest making sure you're with latest SDKs (vst3, aax, etc...)


#5

I'm sure about the 32/64bit... there's no post build script and I have the latest SDKs. But, as wrote in the OP, the project hasn't changed at all. Is there anything I should take care of on Windows 10 in order to successfully compile and run a plugin?

 

Thanks!

 


#6

fixed. it was a file I forgotten to check and formatted in a wrong way. Thank you very much, guys.