Enable AAX + XCODE ERROR -- Solved


#1

Hello felow Jucers,
I am facing this weird issue: :ghost:
I open the JuceDemoPlugin example in Juce 5.2.1 , i save and open in Xcode (9.2) and i successfully build VST AdioUnit and VST3 :smiley:
then i Enable the AAX build, save and open in Xcode and i get Juce modules related errors, and this does not make sense… :rage::rage::rage:
Am i doing something wrong?

if i disable the AAX it builds successfully again …

any ideas?


#2

Do you have the AAX SDK installed? This SDK isn’t publicly available. You have to contact Avid and go through a process to obtain their developer SDKs. Where is aax sdk?


#3

i have installed and build the AAX SDK debug and release build. i have build aax 3 weeks ago without a problem… that is why is very weird… Untitled


#4

What’s the Header Search Paths in the Xcode project?

Rail


#5

is it possible the header search paths to be correct for vst standalone and audio unit and to be wrong when i enable the aax ?


#6

Absolutely. Each project in the solution has it’s own Build Settings

Rail


#7

that is really strange… i cannot spot any difference between the vst au and aax build settings
what is more strange is that if i disable the AAX from juce everything is fine…
any ideas?


#8

These Header Search Paths don’t look very good.
../../JuceLibraryCode is totally fine, but the rest is weird.

Did you really put a folder named SDK'S directly at the root of your file system? Or is it actually in your user folder? (i.e. ~/SDK'S)

Also, ../../JuceLibraryCode/modules should be on its own line, not somehow swallowed by /SDK'S/AAX_SDK_2p3p1/Interfaces/ACF.


#9

And if you want to get your build system into edge cases, putting any kind of quotes is definitively the way to go :wink:

I understand, that spaces in file names should be handled nowadays (I still avoid them), but I really would try to rename your SDK’s folder to SDKs (it is not even proper grammar, it is only supposed for the possesive case (genitive), not for plural).

Try if that fixes the problem, good luck!


#10

yeap, renaming the SDK’s folder and some header changes did the trick :slight_smile:
many thanks!