Error 64-bit when compiling for the first time

Hello, I’m new to JUCE and after creating my first project, a GUI application as the tutorial explain it, I try to compile it with Code::Blocks and I get this error:

“unimplemented: 64-bit mode not compiled in” in the include_juce_audio_basics.cpp
I don’t know what to do and if someone could explain it to me it would be great,
Thank you.

Are you compiling on a 32-bit machine? You might need to set the architecture to be something other than the default (64-bit) in the Code::Blocks build configuration:

Hello ed, no I’m not compiling on a 32-bit machine but I will try your solution, thanks!

When exploring the Projucer it seems that a memory file is missing do you know where could I find it ?

Hi all,

I know this may be a bit late for the above but as I was having the same problem, chances are other’s will have the same problem in the future. So here’s how I resolved it.

TLDR: Download VS 2019 with ‘Desktop development with C++’ workload

First I tried (but did not succeed):
1. Downloading the Mingw64 bit compiler, ensuring my local MingW build Target was x86_64-w64-mingw32.
As per:

2. Updating the compiler for Code Blocks to the above 64bit compiler
As per:

And it still didn’t work, I kept getting the same error.

Then I gave up and downloaded the free community edition of Visual Studio 2019 with the ‘Desktop development with C++’ workload (it’s an option in the installer).

I then created a new project with VS 2019 as the build target. Opened the project in VS, clicked build and it worked!