Errors using Introjucer to create audio plugin


#1

Hi,

I think the Introjucer is a really cool idea because (in theory anyway) it means that I no longer have to worry about my audio plugin code being tightly coupled with a particular version the Juce library code and things breaking due to me forgetting to do things when updating Juce to the latest version.

However I’m just trying to use it for the first time. I take the following steps exactly:

  • Start the Introjucer
  • Select “Download the latest JUCE version” from the Update menu
  • Select a new folder called “Juce” within my Documents folder
  • Click “Check Online For Available Updates”
  • Click “Install This Version” to install version 1.53.103
  • Close the Juce Update window
  • Select “New Project…” from the File menu
  • Select “Audio Plug-In” under “Project Type”
  • Select my “Juce” folder under “Juce Library Location”
  • Click “Next”
  • Select a new folder called “SSP” within my Documents folder for the project location
  • Enter “SSP” under “Project Name”
  • Click “Create Project”
  • Select “Save Project” from the File menu
  • Load the new project in XCode (tried with both 3.2.6 and 4.0.1)
  • Make absolutely no changes to the project
  • Select “Product > Build For > Build For Running”

I then get the error message shown below. Does anyone know where I going wrong? It doesn’t seem as if there is any scope for error in what I am doing.

Cheers,

John.

Error message:

Rez /Users/john/Library/Developer/Xcode/DerivedData/SSP-gdgabyciumkqyhdqodbrodjfkqxn/Build/Intermediates/SSP.build/Debug/SSP.build/ResourceManagerResources/Objects/juce_AU_Resources.rsrc …/…/…/SSP/src/audio/plugin_client/AU/juce_AU_Resources.r
cd /Users/john/Documents/cpp_projects/SSP/Builds/MacOSX
/Developer4/usr/bin/Rez -o /Users/john/Library/Developer/Xcode/DerivedData/SSP-gdgabyciumkqyhdqodbrodjfkqxn/Build/Intermediates/SSP.build/Debug/SSP.build/ResourceManagerResources/Objects/juce_AU_Resources.rsrc -d SystemSevenOrLater=1 -useDF -script Roman -d ppc_$ppc -d i386_YES -d ppc64_$ppc64 -d x86_64_$x86_64 -I /System/Library/Frameworks/CoreServices.framework/Frameworks/CarbonCore.framework/Versions/A/Headers -I /Developer4/Extras/CoreAudio/AudioUnits/AUPublic/AUBase -arch i386 -i /Users/john/Library/Developer/Xcode/DerivedData/SSP-gdgabyciumkqyhdqodbrodjfkqxn/Build/Products/Debug -i /Developer4/Extras/CoreAudio/PublicUtility -i /Developer4/Extras/CoreAudio/AudioUnits/AUPublic/OtherBases -i /Users/john/Documents/cpp_projects/SSP/Builds/MacOSX/…/…/Source -i /Users/john/Documents/cpp_projects/SSP/Builds/MacOSX/…/…/JuceLibraryCode -i /Developer4/Extras/CoreAudio/AudioUnits/AUPublic/AUBase -i /Developer4/Extras/CoreAudio/AudioUnits/AUPublic/AUCarbonViewBase -i /Developer4/Extras/CoreAudio/AudioUnits/AUPublic/AUViewBase -i /Developer4/Extras/CoreAudio/AudioUnits/AUPublic/Utility -i /Users/john/Library/Developer/Xcode/DerivedData/SSP-gdgabyciumkqyhdqodbrodjfkqxn/Build/Products/Debug -i /Users/john/Library/Developer/Xcode/DerivedData/SSP-gdgabyciumkqyhdqodbrodjfkqxn/Build/Products/Debug/include -i /Users/john/SDKs/vstsdk2.4 -i /Developer4/Extras/CoreAudio/PublicUtility -i /Developer4/Extras/CoreAudio/AudioUnits/AUPublic/Utility /Users/john/Documents/cpp_projects/SSP/Builds/MacOSX/…/…/…/SSP/src/audio/plugin_client/AU/juce_AU_Resources.r

/Developer4/usr/bin/Rez - SysError 0 during open of “/Users/john/Documents/cpp_projects/SSP/Builds/MacOSX/…/…/…/SSP/src/audio/plugin_client/AU/juce_AU_Resources.r”.

Fatal Error!

/Developer4/usr/bin/Rez - Fatal Error, can’t recover.

/Users/john/Documents/cpp_projects/SSP/Builds/MacOSX/…/…/…/SSP/src/audio/plugin_client/AU/juce_AU_Resources.r: ### /Developer4/usr/bin/Rez - Since errors occurred, /Users/john/Library/Developer/Xcode/DerivedData/SSP-gdgabyciumkqyhdqodbrodjfkqxn/Build/Intermediates/SSP.build/Debug/SSP.build/ResourceManagerResources/Objects/juce_AU_Resources.rsrc’s resource fork was not written.
Command /Developer4/usr/bin/Rez failed with exit code 3


#2

It looks like it’s failing to read the juce_AU_Resources.r file for some reason, but I don’t know why… Does that file exist?


#3

Hi Jules. Yes, the file exists but where it is looking for it. The relative path that it uses is taking it back into my audio plugin project instead of into the Juce source code where the file can be found. Where the path says “/…/…/…/SSP” it should say “/…/…/…/Juce”. Is this a bug in the Introjucer?


#4

Perhaps you’ve given it the wrong path to your juce directory? That’s where it gets the path from.


#5

No, I’m afraid I followed exactly the steps shown above. I’ve tried it more than once just to be sure :slight_smile:


#6

Are your juce and ssp folders on different disks or something? I really don’t think it’s a bug, far more likely just something set up wrong.


#7

No, they’re just regular folders, side-by-side in a folder called “cpp_projects” within my Documents folder. Looking at the build errors, it definitely appears that the Introjucer is setting the path to the Juce folder incorrectly to point to the project folder instead. I tried again to make sure I’m not going mad but it did exactly the same thing again.


#8

No point in re-creating the project, just check all of its settings, including all the ones under the different compiler targets. And make sure you’re using the latest version of the introjucer (i.e. build it yourself, don’t use the binary from the website).


#9

I built the Introjucer myself using the source code that I downloaded in the steps above (version 1.53.103). The same thing still happens. There is nothing strange in the build settings but in the Xcode project browser the files that are referenced in the Juce library folder are shown in red to indicate that they cannot be found. I haven’t had a chance to test it in Visual Studio yet to see if the same happens there.


#10

In the introjucer’s project settings page, on the ‘Xcode’ tab, it has a relative path to the juce folder. Yours must be set wrong, so check it!


#11

Aha! Sorry Jules. I didn’t realise that any of those settings were there because the window opens up really small, concealing them all. The “Juce Location” field was empty. I had assumed that the path I entered when creating project would be used for this.

Thanks for all your help and sorry for the confusion.

John.


#12

Hello,

If it can help anyone, I also had the same issue with Xcode 4 under OSX Lion.
Paths were correct in introjucer and all, but there were various build issue, until I changed to use the 10.7as Base SDK…
note : that “current OS” was surprisingly not working. I had to specify 10.7

Salvator