Host not loading plugin


#1

I am using Juce 3.0.5 under windows.

I have built the demo host and the demo plugin.

The host does not load the demo plugin or any plugins built with Juce. Any ideas.

I tracked it down to the host trying to get the "main" procedure from the dll and it fails. 


#2

Most likely the host and plugin are using different 32/64 bit architectures.


#3

I check that. I am testing them both as 32 bit. I tried release and debug builds. That was my first guess.

I have my own plugin built with previous versions of juce and it worked but not with 3.0.5.

I will check it again and I hope that is the problem and was my mistake.


#4

I just ran the demo host in 32 bit mode and tried to load the judeDemoPlugin that was built in 32 bit. It will not load.


#5

Well, if it can't load the main function, then something's pretty broken or incompatible between the host and DLL. Maybe a missing dependency DLL?


#6

Well this is 100% juce code straight from the juce 3.0.5.

I am going to test it with the latest juce.


#7


I just tried to build the demoPlugin with the latest juce 3.0.6 and received the following errors


1>fatal error C1083: Cannot open include file: 'pluginterfaces/base/funknown.h': No such file or directory
1>fatal error C1083: Cannot open include file: 'base/source/baseiids.cpp': No such file or directory


I have turn off VST3 and am just using VST2. The host built with no errors.
 


#8

You should use the latest version of the VST3 SDK. It's backwards compatible with VST2, so there's no reason not to use it.


#9

OK, I am trying to download it now, but I am out of town and don't have access to my account info and their automated system to retrieve it is not working.


#10

It does work with the latest juce, so my best guess is the modules are out of sync even though the IntroJucer says they are correct.

Thanks