Inheritance diagram on juce docs in website does not work in mac os El Capitan


#1

Tested with Chrome and Safari, none worked for me
https://www.juce.com/doc/classInputStream

When I generated a copy on my hard drive using DoxyGen, it works perfectly from both.
Just thought you should know.


#2

And it doesn’t work with Firefox nor Chrome on Yosemitee… Already since beginning of the Year… Was mentioned in several threads, extra written for that purpose or as side notes… no response… no bugtracker… no care(?)…


#3

The official JUCE documentation is broken and has been for a long time now. Search disappeared and inheritance and other diagrams are broken. I’d imagine this would leave a bad taste in the mouth of anyone new trying to get into using JUCE. It’s a software library, a type of product which relies heavily on its documentation to illustrate APIs and usage to make new developers want to use it. Having the official documentation on the official site of a software library be half broken and difficult to navigate seems like a perfect way to turn people off from a multi-thousand-dollar commercial product.

Why won’t ROLI fix this??


#4

Yeah, this is seriously starting to annoy me. @_@ Also can’t see the dropdowns for inherited functions and whatnot.

Pleeeeeeease get this fixed, guys!


#5

Yeah, this should really be taken care of by ROLI.

@NoisyNeuron Out of frustration I made one of my servers create the JUCE documentation on a daily basis. It is available at http://klangfreund.github.io/jucedoc/


#6

A fix for this is on its way.


#7

I also tried to group the classes into their corresponding JUCE modules, but a couple of issues stopped me:

  1. The urls to the documentation of every class change, so a lot of the accumulated knowledge in places like this forum becomes invalid.

  2. The urls become too long to be contained within a Ruby gem, which is how the API docs are ultimately served. Doxygen has an option to generate short filenames/urls, but these are not descriptive and are unstable between documentation updates.


#8

I would say grouping into modules is secondary to getting the other basic functionality, search and inheritance diagrams working again.

Also grouping into modules does not need to affect the URL - this could just be how they are presented, or made searchable, although I don’t know what RubyGem you are using or much about Doxygen and how that might affect things. I’d say wanting to know what module a class is in usually comes after finding it!


#9

Fixes for inheritance diagrams and other dropdowns on the page are now live.


#10

Finally, thanks @t0m! :slight_smile:

But the classes on the inheritance diagram are not yet clickable, are they?
It doesn’t work with firefox on OSX 10.10 though…


#11

Correct - the diagram is not clickable.


#12

Awesome, thanks t0m! :slight_smile:


#13

Does that mean Search is fixed?


#14

I don’t see it on Firefox Windows… so no for me at least.


#15

The inheritance diagrams will be hyperlinked soon, probably sometime over the next week. Unfortunately search is harder to fix and I can’t give an ETA.